Modify

#977 closed defect (worksforme)

Specific jabber server doesn't work

Reported by: bitlbee.org@… Owned by: wilmer
Priority: normal Milestone:
Component: Jabber Version: devel
Keywords: jabber, tls Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro: Archlinux

Description

Hi,

I wanted to connect to a specific jabber-server via bitlbee, which doesn't seem to work with bitlbee, but I can connect to it using Psi (which complaints about a self-signed cert though). When trying to connect, all I get is this:

Logging in: Connecting 
Logging in: Connected to server, logging in 
Logging in: Converting stream to TLS
[after two minutes]
Login error: Connection timeout
Logging in: Signing off.
Login error: Short write() to server

The xmlconsole output of Bitlbee looks like this:

TX: <?xml version='1.0' ?><stream:stream to="xmpp.example.com" xmlns="jabber:client" xmlns:stream="http://etherx.jabber.org/streams" version="1.0">
RX: <stream:features><starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls"><required/></starttls><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>JIVE-SHAREDSECRET</mechanism><mechanism>PLAIN</mechanism></mechanisms></stream:features>
TX: <starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls"/>

I compared it to what Psi does, there the XML console prints this:

<?xml version="1.0"?>
 
 
<stream:stream xmlns:stream="http://etherx.jabber.org/streams" version="1.0" xmlns="jabber:client" to="xmpp.example.com" xml:lang="en" xmlns:xml="http://www.w3.org/XML/1998/namespace" >
 
 
<?xml version='1.0' encoding='UTF-8'?><stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" from="xmpp.example.com" id="d0b82c14" xml:lang="en" version="1.0">
 
 
<stream:features>
<mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl">
<mechanism>JIVE-SHAREDSECRET</mechanism>
<mechanism>PLAIN</mechanism>
</mechanisms>
<compression xmlns="http://jabber.org/features/compress">
<method>zlib</method>
</compression>
<auth xmlns="http://jabber.org/features/iq-auth"/>
</stream:features>
 
 
<auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="PLAIN" >censored base64</auth>
 
 
<success xmlns="urn:ietf:params:xml:ns:xmpp-sasl"/>

I couldn't investigate further yet, but it seems like the server tells bitlbee starttls is required, and doesn't tell that to Psi for some reason.

In case you're wondering, the server is the one of the groupchat feature on (attention, not safe for work!) a website called Milovana. (Again, this website is related to sexuality and nsfw!). You need a (free) account to connect to the chat though...

When I set tls to false and ssl to true, I get "Login error: Short write() to server" immediately when trying to log in.

I'm happy to help with testing, and let me know if you need more details.

Flo

Attachments (0)

Change History (2)

comment:1 Changed at 2012-12-23T23:48:20Z by wilmer

Hmm, sorry, did you ever manage to figure this out? Is Psi maybe just connecting to port 5223 and using raw/direct SSL?

comment:2 Changed at 2014-07-11T06:32:32Z by dx

Resolution: worksforme
Status: newclosed

Registered, tried connecting, just worked. Closing ticket!

(Also, that website is way too lewd)

Modify Ticket

Action
as closed The owner will remain wilmer.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.