Modify

#978 closed defect (fixed)

ld: symbol(s) not found for architecture x86_64 / mac os x lion

Reported by: chiappa Owned by: Miklos Vajna
Priority: normal Milestone:
Component: Skype Version: 3.0.5
Keywords: Cc:
IRC client+version: Client-independent Operating System: Public server
OS version/distro:

Description

./configure --prefix=$HOME/opt/bitlbee --skype=1 --events=glib --ssl=gnutls --host=x86_64-darwin

then make gives me:

...
protocols/skype/skype.c:1589: warning: ‘g_strcasecmp’ is deprecated (declared at /opt/local/include/glib-2.0/glib/gstrfuncs.h:173)
Undefined symbols for architecture x86_64:
  "_g_strcasecmp", referenced from:
      _skype_away_state_by_name in ccJvFUGK.o
      _init_plugin in ccJvFUGK.o
      _skype_set_away in ccJvFUGK.o
      _skype_buddy_action in ccJvFUGK.o
  "_g_malloc0_n", referenced from:
      _init_plugin in ccJvFUGK.o
      _skype_login in ccJvFUGK.o
      _skype_parse_user in ccJvFUGK.o
      _skype_parse_call in ccJvFUGK.o
      _skype_parse_group in ccJvFUGK.o
      _skype_call_ask in ccJvFUGK.o
      _skype_buddy_ask in ccJvFUGK.o
      ...
  "_register_protocol", referenced from:
      _init_plugin in ccJvFUGK.o
  "_imcb_new", referenced from:
      _skype_login in ccJvFUGK.o
  "_imcb_log", referenced from:
      _skype_login in ccJvFUGK.o
      _skype_parse_profile in ccJvFUGK.o
      _skype_connected in ccJvFUGK.o
      _skype_parse_user in ccJvFUGK.o
      _skype_parse_call in ccJvFUGK.o
      _skype_parse_filetransfer in ccJvFUGK.o
  "_set_getint", referenced from:
      _skype_login in ccJvFUGK.o
  "_set_getstr", referenced from:
      _skype_login in ccJvFUGK.o
      _skype_parse_chatmessage in ccJvFUGK.o
  "_ssl_connect", referenced from:
      _skype_login in ccJvFUGK.o
  "_ssl_getfd", referenced from:
      _skype_login in ccJvFUGK.o
  "_g_strdup", referenced from:
      _skype_login in ccJvFUGK.o
      _skype_buddy_msg in ccJvFUGK.o
      _skype_get_info in ccJvFUGK.o
      _skype_add_buddy in ccJvFUGK.o
      _skype_remove_buddy in ccJvFUGK.o
      _skype_chat_invite in ccJvFUGK.o
      _skype_chat_with in ccJvFUGK.o
      ...
  "_set_getbool", referenced from:
      _skype_login in ccJvFUGK.o
      _skype_read_callback in ccJvFUGK.o
      _skype_parse_user in ccJvFUGK.o
      _skype_start_stream in ccJvFUGK.o
  "_imcb_add_buddy", referenced from:
      _skype_login in ccJvFUGK.o
      _skype_parse_user in ccJvFUGK.o
      _skype_parse_group in ccJvFUGK.o
      _skype_parse_alter_group in ccJvFUGK.o
  "_set_eval_account", referenced from:
      _skype_init in ccJvFUGK.o
  "_set_add", referenced from:
      _skype_init in ccJvFUGK.o
  "_set_eval_int", referenced from:
      _skype_init in ccJvFUGK.o
  "_set_eval_bool", referenced from:
      _skype_init in ccJvFUGK.o
  "_imcb_chat_free", referenced from:
      _skype_logout in ccJvFUGK.o
      _skype_parse_chat in ccJvFUGK.o
  "_g_list_length", referenced from:
      _skype_logout in ccJvFUGK.o
      _skype_add_buddy in ccJvFUGK.o
      _skype_group_free in ccJvFUGK.o
      _skype_group_by_username in ccJvFUGK.o
      _skype_parse_chatmessage in ccJvFUGK.o
      _skype_parse_group in ccJvFUGK.o
      _skype_parse_alter_group in ccJvFUGK.o
      ...
  "_g_list_nth_data", referenced from:
      _skype_logout in ccJvFUGK.o
      _skype_add_buddy in ccJvFUGK.o
      _skype_group_free in ccJvFUGK.o
      _skype_group_by_username in ccJvFUGK.o
      _skype_parse_chatmessage in ccJvFUGK.o
      _skype_parse_group in ccJvFUGK.o
      _skype_parse_alter_group in ccJvFUGK.o
      ...
  "_g_free", referenced from:
      _skype_logout in ccJvFUGK.o
      _skype_buddy_msg in ccJvFUGK.o
      _skype_add_buddy in ccJvFUGK.o
      _skype_remove_buddy in ccJvFUGK.o
      _skype_chat_invite in ccJvFUGK.o
      _skype_chat_with in ccJvFUGK.o
      _skype_buddy_action in ccJvFUGK.o
      ...
  "_set_find", referenced from:
      _skype_set_my_name in ccJvFUGK.o
  "_g_list_append", referenced from:
      _skype_away_states in ccJvFUGK.o
      _skype_parse_chatmessage in ccJvFUGK.o
      _skype_parse_group in ccJvFUGK.o
      _skype_parse_alter_group in ccJvFUGK.o
  "_imcb_chat_new", referenced from:
      _skype_chat_with in ccJvFUGK.o
      _skype_parse_chat in ccJvFUGK.o
  "_g_list_prepend", referenced from:
      _skype_buddy_action_list in ccJvFUGK.o
  "_imcb_error", referenced from:
      _skype_buddy_action in ccJvFUGK.o
      _skype_set_call in ccJvFUGK.o
      _skype_connected in ccJvFUGK.o
      _skype_read_callback in ccJvFUGK.o
      _skype_parse_call in ccJvFUGK.o
      _skype_parse_password in ccJvFUGK.o
  "_imc_logout", referenced from:
      _skype_connected in ccJvFUGK.o
      _skype_read_callback in ccJvFUGK.o
      _skype_parse_password in ccJvFUGK.o
      _skype_write in ccJvFUGK.o
      _skype_printf in ccJvFUGK.o
  "_ssl_read", referenced from:
      _skype_read_callback in ccJvFUGK.o
  "_g_strsplit", referenced from:
      _skype_read_callback in ccJvFUGK.o
      _skype_parse_users in ccJvFUGK.o
      _skype_parse_chat in ccJvFUGK.o
      _skype_parse_group in ccJvFUGK.o
      _skype_parse_chats in ccJvFUGK.o
      _skype_parse_groups in ccJvFUGK.o
  "_imcb_buddy_msg", referenced from:
      _skype_read_callback in ccJvFUGK.o
      _skype_parse_chatmessage in ccJvFUGK.o
  "_g_strfreev", referenced from:
      _skype_read_callback in ccJvFUGK.o
      _skype_parse_users in ccJvFUGK.o
      _skype_parse_chat in ccJvFUGK.o
      _skype_parse_group in ccJvFUGK.o
      _skype_parse_chats in ccJvFUGK.o
      _skype_parse_groups in ccJvFUGK.o
  "_closesocket", referenced from:
      _skype_read_callback in ccJvFUGK.o
  "_g_strdup_printf", referenced from:
      _skype_parse_user in ccJvFUGK.o
      _skype_parse_chatmessage in ccJvFUGK.o
      _skype_parse_chat in ccJvFUGK.o
      _skype_parse_group in ccJvFUGK.o
      _skype_parse_alter_group in ccJvFUGK.o
      _skype_buddy_ask in ccJvFUGK.o
  "_imcb_buddy_status", referenced from:
      _skype_parse_user in ccJvFUGK.o
  "_imcb_ask", referenced from:
      _skype_parse_user in ccJvFUGK.o
      _skype_parse_call in ccJvFUGK.o
      _skype_call_ask in ccJvFUGK.o
      _skype_buddy_ask in ccJvFUGK.o
  "_bee_user_by_handle", referenced from:
      _skype_parse_user in ccJvFUGK.o
  "_g_string_new", referenced from:
      _skype_parse_user in ccJvFUGK.o
  "_g_string_append_printf", referenced from:
      _skype_parse_user in ccJvFUGK.o
  "_g_string_free", referenced from:
      _skype_parse_user in ccJvFUGK.o
  "_bee_chat_by_title", referenced from:
      _skype_parse_chatmessage in ccJvFUGK.o
      _skype_parse_chat in ccJvFUGK.o
  "_g_snprintf", referenced from:
      _skype_parse_chatmessage in ccJvFUGK.o
      _skype_parse_call in ccJvFUGK.o
      _skype_parse_chat in ccJvFUGK.o
  "_imcb_chat_msg", referenced from:
      _skype_parse_chatmessage in ccJvFUGK.o
  "_imcb_chat_topic", referenced from:
      _skype_parse_chatmessage in ccJvFUGK.o
      _skype_parse_chat in ccJvFUGK.o
  "_imcb_chat_remove_buddy", referenced from:
      _skype_parse_chatmessage in ccJvFUGK.o
  "_g_list_free", referenced from:
      _skype_parse_chatmessage in ccJvFUGK.o
  "_imcb_chat_name_hint", referenced from:
      _skype_parse_chat in ccJvFUGK.o
  "_imcb_chat_add_buddy", referenced from:
      _skype_parse_chat in ccJvFUGK.o
  "_g_list_find_custom", referenced from:
      _skype_parse_chat in ccJvFUGK.o
  "_log_message", referenced from:
      _skype_parse_group in ccJvFUGK.o
      _skype_parse_alter_group in ccJvFUGK.o
  "_imcb_connected", referenced from:
      _skype_parse_password in ccJvFUGK.o
  "_ssl_write", referenced from:
      _skype_write in ccJvFUGK.o
      _skype_printf in ccJvFUGK.o
  "_b_input_add", referenced from:
      _skype_start_stream in ccJvFUGK.o
ld: symbol(s) not found for architecture x86_64
collect2: ld returned 1 exit status
make: *** [skype.so] Error 1

using mac os x lion 10.7.4, xcode 4.3.2

Attachments (0)

Change History (7)

comment:1 Changed at 2012-08-19T15:36:02Z by wilmer

Component: BitlBeeSkype
Owner: set to Miklos Vajna

Seems to be an issue with how the Skype module is built?

comment:2 Changed at 2012-08-19T20:53:22Z by Miklos Vajna

Hi chiappa,

Have you tried building the otr plugin? I'm asking just to see if this is something specific to skype or it's a general plugin issues.

I have no access to an OSX machine to check myself (but I did have an iBook in the past, and before it died, I used the skype plugin on it without issues, so it should be possible to fix it).

Thanks,

Miklos

comment:3 Changed at 2013-02-28T23:00:52Z by bitlbee@…

Confirmed getting the same error on OSX today.

Using the bzr checkout at revno 977

./configure --otr=1 --skype=1 --msn=0 --yahoo=0
make
...
* Linking bitlbee
ld: warning: directory not found for option '-L/lib'
* Stripping bitlbee
* Building plugin skype
Undefined symbols for architecture x86_64:
  "_b_input_add", referenced from:
      _skype_start_stream in ccVMV753.o
  "_bee_chat_by_title", referenced from:
...
  "_ssl_write", referenced from:
      _skype_write in ccVMV753.o
      _skype_printf in ccVMV753.o
ld: symbol(s) not found for architecture x86_64
collect2: ld returned 1 exit status
make: *** [skype.so] Error 1

Using i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc. build 5658) for the build.

comment:4 Changed at 2013-02-28T23:05:11Z by Jinn Ko <bitlbee@…>

Also confirmed the same issue with the official bitlbee-3.2.tar.gz release.

comment:5 Changed at 2013-03-01T06:40:48Z by Miklos Vajna

Excellent, so you guys still failed to answer what I asked in comment 2. ;-)

Anyway, please test if this patch helps:

http://people.freedesktop.org/~vmiklos/2013/bitlbee-skype-osx.patch

Build with ./configure --skype=1 --msn=0 --yahoo=0

To make sure you don't report OTR problem in this Skype ticket.

comment:6 Changed at 2013-03-01T10:11:18Z by Jinn Ko <bitlbee@…>

Great! The patch works and the bzr repo compiles successfully now!

Apologies, forgot to mention that I had tried several variations:

  • --otr=1 --skype=0 compiled successfully.
  • --otr=0 --skype=1 resulted in the same error.
  • --otr=0 --skype=1 --ssl=openssl failed with some ssl errors before reaching the skype compile.

Thanks for the quick patch!

comment:7 Changed at 2013-03-03T14:54:44Z by Miklos Vajna

Resolution: fixed
Status: newclosed

Fixed in r977.1.3.

Modify Ticket

Action
as closed The owner will remain Miklos Vajna.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.