Modify

#482 closed defect (fixed)

Joining a Google Talk group chat causes Segmentation Fault

Reported by: james2vegas@… Owned by: wilmer
Priority: major Milestone:
Component: Jabber Version: 1.2.3
Keywords: Cc:
IRC client+version: Client-independent Operating System: OpenBSD
OS version/distro:

Description

Google Talk user (on the Flash applet) adds a bitlbee user to their group chat (or a bitlbee user creates a Google Talk group chatand invites a Google Talk user into it), as soon as the other person joins the room (Google Talk shows them successfully joining), bitlbee segfaults in jabber_chat_pkt_presence

This is a partial IRC log: --- (root) jabber - Message from unknown handle private-chat-6fecd6ed-a458-461a-8410-51b604070e48@…: (root) You've been invited to this chat room! (root) Click here to join: http://talkgadget.google.com/talkgadget/joinpmuc?r=Cm9_IhdpAbO5ZURyos2AuSYkCPd10WsEcngN1EEXWV2OwuhMpjALeaqRqeJG7EhXqIuPgYegfePeabwkvnNxtOUVPU_riOhdvH83tUBTl-g-WAi_r9P_qnmbojYu9z1pHvJJrrbHTbz8HJNqXOWMyZoSDErSK06X43LVF7QXgxgB&si=1 (bitler) join_chat 0 private-chat-6fecd6ed-a458-461a-8410-51b604070e48@… &foo [a] join(&foo): bitler(bitler@…) .------ ----------- - ------[&clem (members: 2)]--------------- -- - | [bitler] [root ] `-�� �----------------- -- -[ops: 0 nonops: 2]---�---------- --- - [a] (topic.&foo): BitlBee groupchat: "private-chat-6fecd6ed-a458-461a-8410-51b604070e48@…". Please keep in mind that root-commands won't work here. Have fun!


at which point bitlbee segfaults

backtrace (bitlbee run in gdb with -n):

#0 jabber_chat_pkt_presence (ic=0x86806000, bud=0x7fa384c0, node=0x3c00eafc)

at conference.c:232

#1 0x1c024768 in jabber_pkt_presence (node=0x7fa391e0, data=0x86806000)

at presence.c:100

#2 0x1c019570 in xt_handle (xt=0x7e4e8f80, node=0x7fa391e0, depth=0)

at xmltree.c:191

#3 0x1c019501 in xt_handle (xt=0x7e4e8f80, node=0x7e4e8f20, depth=1)

at xmltree.c:171

#4 0x1c02041d in jabber_read_callback (data=0x86806000, fd=10,

cond=GAIM_INPUT_READ) at io.c:177

#5 0x1c01547a in gaim_io_invoke (source=0x82d83f40, condition=0,

data=0x7d3dd530) at events_glib.c:84

#6 0x04a90ae3 in g_vasprintf () from /usr/local/lib/libglib-2.0.so.1800.1

#7 0x04a632a5 in g_source_is_destroyed ()

from /usr/local/lib/libglib-2.0.so.1800.1

#8 0x04a642ad in g_main_context_dispatch ()

from /usr/local/lib/libglib-2.0.so.1800.1

#9 0x04a645d2 in g_main_context_dispatch ()

from /usr/local/lib/libglib-2.0.so.1800.1

#10 0x04a64ad6 in g_main_loop_run () from /usr/local/lib/libglib-2.0.so.1800.1 #11 0x1c015431 in b_main_run () at events_glib.c:63 #12 0x1c013dd7 in main (argc=6, argv=0xcfbe2d00) at unix.c:135

This happens on the public server too (though I can't get a backtrace from there, the server just disconnects)

Attachments (0)

Change History (8)

comment:1 Changed at 2009-03-14T00:49:37Z by james2vegas@…

Of course 'OpenBSD' as operating system is probably misleading here, it is where I encountered the problem, but there is nothing in the code that makes it specific to that OS

comment:2 Changed at 2009-08-27T15:14:57Z by tim@…

I also can't connect to a gtalk group chat. It is described well above, using the same steps as above on a linux machine with version 1.2.3 I am disconnected after trying the join_chat command. I didn't capture a segfault but I got this message in my syslog 'bitlbee[31083]: Fatal signal received: 11. That's probably a bug.'

comment:3 Changed at 2009-08-27T15:20:08Z by Wilmer van der Gaast <wilmer@…>

I think this is a known bug. Can you try a recent bzr snapshot?

comment:4 Changed at 2009-08-27T18:06:58Z by tim@…

I just tried downloading, building and running from bzr and now I can't even identify myself. I don't know if there is a bug in the version I got or if I built it wrong. Is there a particular snapshot I should try? Even better a build for CentOS 5 x86_64 that I can just download and try?

comment:5 Changed at 2009-10-02T23:25:20Z by wilmer

Sorry for lagging so much.. :-( Have you figured this out? The id problems were probably caused by your own-compiled bitlbee not running as the same user as the packaged BitlBee you used before.

comment:6 Changed at 2009-10-05T14:36:50Z by tim@…

I never figured it out I just stopped using BitlBee for google talk group chats. Does anyone use it in this way? Besides this bug report I couldn't find any reference to anyone using google talk group chat with BitlBee.

comment:7 Changed at 2009-10-05T14:44:11Z by Wilmer van der Gaast <wilmer@…>

I (and many colleagues with me) use BitlBee for a groupchat at work since June 2007 already. There were some issues with a certain flavour of chatrooms a little while ago, but those should also be resolved now. 1.2.3 is still broken on those though, most likely.

If you want to try it again, you can try it out on testing.bitlbee.org which runs fixed code.

comment:8 Changed at 2010-03-10T09:44:53Z by wilmer

Resolution: fixed
Status: newclosed

Should be fixed for a while already, let me know if this is still broken.

Modify Ticket

Action
as closed The owner will remain wilmer.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.