#11 closed defect (obsolete)

Permission problems win32 port

Reported by: kroesjnov Owned by: Jelmer Vernooij
Priority: major Milestone:
Component: BitlBee Version: 0.99
Keywords: win32 permissions read-only Cc:
IRC client+version: Client-independent Operating System: Windows
OS version/distro: Windows XP


Problem: Error message Configuration could not be saved''.

When: Attempt to register an account on the win32 port of the Bitlbee server.

Likely Cause: The default config directory resides in C:\Documents and Settings\$user\Application Data\ which is a directory with read-only permission. These permission are inherited by directories below this directory.

Attachments (2)

fix.reg (342 bytes) - added by Orbixx at 2007-09-24T10:27:07Z.
Fix for this configuration bug.
fix.2.reg (254 bytes) - added by Orbixx at 2007-09-24T10:29:59Z.
Revised .reg fix. Copy and paste into notepad and save as .reg file. Don't use previous version.

Download all attachments as: .zip

Change History (10)

comment:1 Changed at 2005-11-14T22:03:22Z by wilmer

Owner: changed from Jelmer to Jelmer Vernooij
Priority: criticalmajor

Let's stick with major, it's more a bad default setting than a real bug that makes the program unusable.

(And I don't know if this stuff is case sensitive, but if it is, I just fixed the reference.. :-)

comment:2 Changed at 2005-11-15T00:34:05Z by Jelmer Vernooij

Status: newassigned

I hope to have this fixed when I release the new service-based Win32 port for 0.99.

There is no 0.99 build of the Windows port yet, so I guess the version number specified for this bug report is incorrect?

comment:3 Changed at 2005-12-11T16:52:25Z by kroesjnov

No idea what version really, reported for somebody else and forgot to ask. Assume latest version I guess... Seen the problem in #bitlbee multiple times and got tired of people not reporting it :)

comment:4 Changed at 2005-12-14T23:26:32Z by surreal.w00t@…

Not sure about other people, but both times I've tried the w32 port [I use it often..] the directory under Application Data/ hasn't even been created.

Either way, is it at least possible to document this? It took me way too long to figure this out on my own [back before this tracker item existed, I think was when I first tried :p]

comment:5 Changed at 2006-01-31T15:25:42Z by anonymous

i was about te report this one.

Actually, you only need to add the creation of the default config path in the installation.

To fix the problem if you already installed bitlbee, create it manually. That's what i did, and i didnt had any problem since then.

As for the version, i had this problem with v0.92.

comment:6 Changed at 2007-09-24T07:33:40Z by Orbixx

Surely this one can't be so difficult to fix?

Changed at 2007-09-24T10:27:07Z by Orbixx

Attachment: fix.reg added

Fix for this configuration bug.

comment:7 Changed at 2007-09-24T10:27:26Z by anonymous

Fixed, somewhat. Changing the config path does the job just fine.

For the somewhat technically challenged, I've uploaded a .reg file for you to open up which will change the config path for you to a sensible location and that will solve the problem for you. Restart Bitlbee after applying the .reg patch.

The file can be found above.

Changed at 2007-09-24T10:29:59Z by Orbixx

Attachment: fix.2.reg added

Revised .reg fix. Copy and paste into notepad and save as .reg file. Don't use previous version.

comment:8 Changed at 2012-03-25T23:39:31Z by wilmer

Resolution: obsolete
Status: assignedclosed

win32 port is unsupported anyway.

Modify Ticket

as closed The owner will remain Jelmer Vernooij.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.