Modify

#944 closed defect (duplicate)

frequent segfaults when twitter account is enabled

Reported by: palehose@… Owned by:
Priority: normal Milestone:
Component: BitlBee Version: 3.0.5
Keywords: Cc:
IRC client+version: weechat 0.3.7 Operating System: Linux
OS version/distro: Arch Linux

Description

This just started happening within the last couple days. I didn't see anything in the bug tracker or the bitlbee twitter feed, so I hope this isn't a duplicate report.

Anyway, I've attached a core dump. Here is the backtrace:

GNU gdb (GDB) 7.4
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/sbin/bitlbee...done.
[New LWP 19417]

warning: Can't read pathname for load map: Input/output error.
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".
Core was generated by `/usr/sbin/bitlbee -Dn'.
Program terminated with signal 11, Segmentation fault.
#0  0x0000000000465c0f in twitter_http_get_home_timeline (req=0x1eb1980) at twitter_lib.c:911
911             twitter_xt_get_status_list(ic, parser->root, txl);
(gdb) bt
#0  0x0000000000465c0f in twitter_http_get_home_timeline (req=0x1eb1980) at twitter_lib.c:911
#1  0x0000000000424d79 in http_incoming_data (data=0x1eb1980, source=<optimized out>, cond=cond@entry=B_EV_IO_READ) at http_client.c:495
#2  0x0000000000424435 in gaim_io_invoke (data=0x1eb0ec0, condition=<optimized out>, source=<optimized out>) at events_glib.c:88
#3  gaim_io_invoke (source=<optimized out>, condition=<optimized out>, data=0x1eb0ec0) at events_glib.c:72
#4  0x00007fa39e1ed8bd in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#5  0x00007fa39e1ee0b8 in ?? () from /usr/lib/libglib-2.0.so.0
#6  0x00007fa39e1ee5f2 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#7  0x00000000004244ac in b_main_run () at events_glib.c:64
#8  0x0000000000410958 in main (argc=<optimized out>, argv=0x7fffe4d13dd8) at unix.c:183
(gdb)

Attachments (0)

Change History (11)

comment:1 Changed at 2012-04-13T14:37:14Z by palehose@…

Can't upload core dump, it's too large even when gzipped. Here's a link: http://ompldr.org/vZGQyNg/core.bitlbee.19417.gz

Also, it just segfaulted again with the twitter account disabled. Same information in backtrace this time. Why would it be calling twitter functions when no twitter account is enabled?

comment:2 Changed at 2012-04-13T14:41:47Z by palehose@…

OK, I still had my twitter message buffer open, maybe that had something to do with it? Closed it, will report if I continue to see segfaults.

comment:3 Changed at 2012-04-13T14:43:38Z by Wilmer van der Gaast <wilmer@…>

Most likely this problem doesn't appear if you use libevent instead of glib. Would it be hard to confirm this?

comment:4 Changed at 2012-04-13T14:46:58Z by palehose@…

I rebuilt with --events=libevent, will let you know if I continue to see issues.

comment:5 Changed at 2012-04-13T14:56:20Z by palehose@…

Another segfault:

warning: Can't read pathname for load map: Input/output error.
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".
Core was generated by `/usr/sbin/bitlbee -F'.
Program terminated with signal 11, Segmentation fault.
#0  0x0000000000465f1f in twitter_http_get_home_timeline (req=0x1613620) at twitter_lib.c:911
911             twitter_xt_get_status_list(ic, parser->root, txl);
(gdb) bt
#0  0x0000000000465f1f in twitter_http_get_home_timeline (req=0x1613620) at twitter_lib.c:911
#1  0x0000000000425089 in http_incoming_data (data=0x1613620, source=<optimized out>, cond=<optimized out>) at http_client.c:495
#2  0x00000000004247df in b_event_passthrough (fd=10, event=<optimized out>, data=0x165f9b0) at events_libevent.c:147
#3  0x00007f793e2d9873 in event_base_loop () from /usr/lib/libevent-2.0.so.5
#4  0x0000000000424400 in b_main_run () at events_libevent.c:86
#5  0x0000000000410898 in main (argc=<optimized out>, argv=0x7fff2c4ba018) at unix.c:183
(gdb)

comment:6 Changed at 2012-04-14T10:04:56Z by wilmer

Ok, my lame theory fails. This is odd. What does "print parser" show you? And maybe helpful, "bt full"?

comment:7 Changed at 2012-04-14T10:06:26Z by wilmer

Oh yes, I realise you gave a coredump now, but without the exact same binary I can't use that. :-( Would've been quite helpful otherwise (but be careful with posting it publicly as it does also contain your Twitter credentials!).

comment:8 Changed at 2012-04-14T19:51:29Z by palehose@…

Here's a link to the binary (gzipped): http://ompldr.org/vZGRrZA/bitlbee.gz

And thanks for the heads-up on my user credentials being part of the core dump. I had not considered that. I have changed my password.

Let me know if I can do anything else to help you troubleshoot.

comment:9 Changed at 2012-04-30T19:57:13Z by wilmer

Hm, drat:

(gdb) bt
#0  0x0000000000465c0f in twitter_flush_timeline (ic=<optimized out>) at twitter_lib.c:797
#1  0x0000000000000000 in ?? ()

Looks like I was wrong and just the binary isn't enough. :-( I assume this is still happening to you?

comment:10 Changed at 2012-04-30T21:35:44Z by palehose@…

Not recently. I have had twitter disabled since this started happening, though.

comment:11 Changed at 2012-11-25T20:24:11Z by wilmer

Resolution: duplicate
Status: newclosed

This was probably a duplicate of #953, which was fixed a while ago.

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.