Modify

#872 closed defect (fixed)

Unable to reply to twitter (therefor identi.ca/status.net) posts

Reported by: sudaraka.wijesinghe@… Owned by:
Priority: normal Milestone:
Component: Twitter Version: 3.0.3
Keywords: Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro: Archlinux

Description

I recently upgraded to bitlbee 3.0.4, after the upgrade when I try to reply to a post on Twitter based account "reply 23 blah blah", I get the following message and can't make the reply.

"User `23' does not exist or didn't post any statuses recently"

Other commands (post, undo, rt, etc.) works fine.

Could someone please look into this issue? and let me know if I need to provide more details.

Attachments (0)

Change History (24)

comment:1 Changed at 2011-12-17T09:34:02Z by Wilmer van der Gaast <wilmer@…>

Weird. Does it work if you put a # in front of the number?

comment:2 in reply to:  1 Changed at 2011-12-17T09:36:39Z by anonymous

Replying to Wilmer van der Gaast <wilmer@…>:

Weird. Does it work if you put a # in front of the number?

Yes, it's same with or without #

comment:3 Changed at 2011-12-17T09:39:24Z by Wilmer van der Gaast <wilmer@…>

Oh, was it a tweet of your own? I.e. were you trying to reply to yourself?

comment:4 in reply to:  3 Changed at 2011-12-17T09:44:30Z by anonymous

Replying to Wilmer van der Gaast <wilmer@…>:

Oh, was it a tweet of your own? I.e. were you trying to reply to yourself?

Some of them were my own, I get the message when I try to reply to others as well.

comment:5 Changed at 2011-12-17T13:44:02Z by wilmer

Can you reproduce this in a fresh session? Right now I'm unable to reproduce this myself:

14:41:39 < BitlBee___> [2011-12-13 01:29:36] [19] BTW, if you're using the Debian/Ubuntu nightly 
                       repo and still stuck with version 779, see http://t.co/UZt75fD0 
                       <bugs.bitlbee.org/bitlbee/ticket…>
14:41:39 -!- Irssi: Join to #twitter_BitlBeeTest2 was synced in 0 secs
14:41:44 <@wilmer> reply 19 hoi
14:42:38 <@root> You: [20->19] @BitlBee hoi

For replying to yourself, this functionality currently does not work. I'm not aware of any other problems though, and don't see how it could fail.

comment:6 in reply to:  5 Changed at 2011-12-17T14:14:36Z by anonymous

Replying to wilmer:

Can you reproduce this in a fresh session? Right now I'm unable to reproduce this myself:

14:41:39 < BitlBee___> [2011-12-13 01:29:36] [19] BTW, if you're using the Debian/Ubuntu nightly 
                       repo and still stuck with version 779, see http://t.co/UZt75fD0 
                       <bugs.bitlbee.org/bitlbee/ticket…>
14:41:39 -!- Irssi: Join to #twitter_BitlBeeTest2 was synced in 0 secs
14:41:44 <@wilmer> reply 19 hoi
14:42:38 <@root> You: [20->19] @BitlBee hoi

For replying to yourself, this functionality currently does not work. I'm not aware of any other problems though, and don't see how it could fail.

This is from my identi.ca account

<sajiniuthpala_> [19:30:02] [52] test...
<sudaraka> reply 52 test reply
<root> User `52' does not exist or didn't post any statuses recently

And, this is from the twitter account

<sajiniuthpala> [19:33:28] [39] test
<sudaraka> reply 39 test reply
<root> You: [40->39] @sajiniuthpala test reply

Please note that I'm not saying it works for Twitter and fails for Identi.ca, chances of success fails seems to be random for both accounts.

Also, I should note that I'm on an unstable ADSL connection. It disconnects some time resulting in changing my WAN IP, don't know if it has something to do with this. However I have noticed the issue while the internet connection is stable for hours.

P.S. Thank you for taking interest in this matter and your prompt replies.

comment:7 Changed at 2011-12-18T00:56:41Z by anonymous

#831 dupe

comment:8 Changed at 2011-12-18T19:44:56Z by wilmer

No problem.

That's weird, so at least from what you can see this is specific to using identi.ca (or replying to yourself on normal Twitter)?

comment:9 Changed at 2011-12-19T09:31:38Z by wilmer

Oh yes, one more thing: Do you have the same problem with retweets?

comment:10 in reply to:  9 Changed at 2011-12-19T10:34:25Z by anonymous

Replying to wilmer:

Oh yes, one more thing: Do you have the same problem with retweets?

Well, as I mentioned it worked on the time I tried to capture the example to post here. But it had happened to me on both Twitter and Identi.ca accounts, and it seem to happen in random occurrences. And, I didn't notice the problem in re-tweets, but then I don't re-tweet much (or at all).

Yesterday, the whole day the problem didn't occur, more an more I suspect my unstable internet connection. Is there a possibility that might be the case?

Can you tell me how to log or trace the index bitlbee keep for each post?

comment:11 Changed at 2011-12-19T10:46:51Z by wilmer

With Twitter, I don't think this should be possible, unless an interruption of your Internet connection means you end up reconnecting to BitlBee? For Twitter, BitlBee just polls an HTTP server every minute to get updates, there's no persistent connection. It will cause temporary fetch failures, but as soon as the connection comes back, BitlBee will catch up.

However, if you for some reason do get disconnected from BitlBee, the show_ids numbers from the last session will definitely not work in the new session.

comment:12 Changed at 2011-12-19T10:50:53Z by wilmer

Oh yes, so there's no very useful logging here I'm afraid.

The error you're getting can happen either when the number isn't recognised, or when BitlBee can no longer find the contact that posted the status you're trying to respond to (it needs it to figure out what @screenname prefix to use).

Oh yes, I do assume you always use mode=chat?

comment:13 in reply to:  12 Changed at 2011-12-19T17:48:10Z by anonymous

Replying to wilmer:

Oh yes, so there's no very useful logging here I'm afraid.

The error you're getting can happen either when the number isn't recognised, or when BitlBee can no longer find the contact that posted the status you're trying to respond to (it needs it to figure out what @screenname prefix to use).

Oh yes, I do assume you always use mode=chat?

Yes, I using mode=chat for both accounts and I run Bitlbee deamon on my localhost therefor not loosing connection between irc client and the Bitlbee.

comment:14 Changed at 2011-12-23T08:21:58Z by rikai <winter.blood@…>

I can confirm this bug, at least on the twitter side as documented in bug #876

comment:15 Changed at 2011-12-23T08:24:28Z by wilmer

So neither of you has been able to discover a pattern in this by the way? And rikai, have you seen this problem with retweets or just with replies?

comment:16 Changed at 2011-12-23T08:28:36Z by rikai <winter.blood@…>

I don't ever really retweet, so i'm not sure if there's an issue with that.

There's no pattern that i can see. It either just works, or doesn't work. I can do replies most of the time, but every once in a while (a few times a day), it just refuses to allow a reply. I can reply to tweets that appear after that, even ones from the same user, just not that specific tweet.

My bitlbee server is also hosted locally, so i don't believe it's a connection problem either.

comment:17 in reply to:  15 Changed at 2011-12-23T13:54:16Z by Sudaraka Wijesinghe <sudaraka.wijesinghe@…>

Replying to wilmer:

So neither of you has been able to discover a pattern in this by the way? And rikai, have you seen this problem with retweets or just with replies?

Just noticed both rikai and I are using Archlinux, Could that be related to this issue? Maybe something with the packaging? I must add that I'm using the 64bit version.

comment:18 Changed at 2011-12-29T22:06:02Z by wilmer

That'd be pretty unlikely..

Is one of you handy with gdb?

What I'm guessing is that somehow bu == NULL (or points to an incorrect user) on twitter.c:541 <http://bugs.bitlbee.org/bitlbee/browser/devel/protocols/twitter/twitter.c?rev=devel%2C868#L541>. I just don't know how that could happen.

comment:19 Changed at 2012-01-02T13:54:07Z by anonymous

I cannot find a pattern. It happens to me on both Identica and Twitter, and it appears to be entirely random. I must login to the site, to reply to the post. I'm not sending replies to myself, and when logging into the site, the account that I wish to reply to exists. I've not tested retweets explicitly, and I don't recall whether or not I got this issue on a retweet.

comment:20 Changed at 2012-03-25T23:34:15Z by wilmer

Priority: majornormal

comment:21 Changed at 2012-05-19T06:18:21Z by sergiosdj@…

Ticket #962 is related to this one.

comment:22 Changed at 2012-05-19T06:36:22Z by Sergio Durigan Junior <sergiosdj@…>

While debugging #962, I noticed an interesting thing. I tried to post a reply to a message whose ID was 21 on Identi.ca, and I received:

<@root> | User `21' does not exist or didn't post any statuses recently

However, when I went to the Identi.ca, my reply was actually there! I was running a network sniffer at the moment, and I could confirm that bitlbee posted the message, even after giving me the error above.

comment:23 Changed at 2012-11-14T14:57:51Z by wilmer

Ah, you found this bug yourself already. :-)

Anyway, I'm pretty sure I know what's going on and I know how to fix this. This is only happening with mentions/etc. from people you don't follow. Just saw it happening here as well. I had this theory for a long time but nobody has confirmed it for me...

WIll fix it in the 1.1 semi-rewrite.

comment:24 Changed at 2012-12-07T00:04:53Z by wilmer

Resolution: fixed
Status: newclosed

Closing this one in favour of #996. This bug has been fixed in the JSON branch (streaming mode only), which will be merged and release fairly soon.

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.