#861 closed enhancement (worksforme)

A decent update mechanism for bitlbee in irssi

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: BitlBee Version: 3.0.3
Keywords: Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro:


The update mechanism for bitlbee is not acting "decent" when bitlbee is run in irssi. Well, decent is not exactly the correct term for it, but you know what I mean.

The problem is that when updating the bitlbee executable is definitely updated, but somehow irssi sticks to the old one in memory and refuses to load the updated one. The only solution to solve this right now is messing with irssi until catches on.

Attachments (0)

Change History (5)

comment:1 Changed at 2011-11-15T03:44:14Z by anonymous

Just another observation:

I managed to make irrsi aware of the new Bitlbee version (825). I discovered that logging in on MSN still fails the first attempt on getting the buddy list but on the second attempt it succeeds immediately. So you did a great job in solving that issue. Good work, gentlemen.

comment:2 Changed at 2011-11-15T06:45:26Z by Wilmer van der Gaast <wilmer@…>

Assuming your BitlBee is running in ForkDaemon mode, all you need to do is reconnect. Obviously just installing a new binary without reconnecting isn't going to magically get you connected to a new BitlBee version.

comment:3 Changed at 2011-11-16T15:34:57Z by wilmer

Resolution: worksforme
Status: newclosed

Feel free to comment if anything of the above is not clear. It doesn't like there's anything to be improved in BitlBee here.

comment:4 Changed at 2011-11-18T03:28:21Z by anonymous

Yes, I do now know that reconnecting does the trick.

I was confused about the restarting procedure that almost all Linux programs do after being updated. However I found out that bitlbee does restart itself but irssi does not (because it is not updated) and of course bitlbee can't touch irssi. So I confirm it works for me too.

Thanks for the explanation.

comment:5 Changed at 2011-11-18T04:32:05Z by wilmer

Yes, the forkdaemon master process is restarted but your serving child process is not. Just like when your browser/terminal/X/etc gets upgraded by apt-get or so, it doesn't automatically get killed/restarted as that could be pretty frustrating.

Modify Ticket

as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.