Modify

#83 closed defect (fixed)

Comma in password mishandled (at least for MSN account)

Reported by: sv8hxzp02@… Owned by: wilmer
Priority: minor Milestone:
Component: MSN Version:
Keywords: Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro:

Description

I had problem with my MSN password. Bitlbee accepted my password but connecting to passport service always failed. All other accounts worked fine (different passwords). After numerous tries on 2 bitlbee servers (ver 0.92) and also on im.bitlbee.org I started to suspect special characters in my password and found out that bitlbee does not like comma(,) in my password. After removing comma from my password MSN signs in just fine.

I tried this MSN only, not on other accounts.

Attachments (0)

Change History (6)

comment:1 Changed at 2006-01-10T10:45:50Z by wilmer

Okay, I know where this goes wrong. A small change in http_encode() should fix this, and hopefully it won't cause problems at other places. I'll change it later today.

comment:2 Changed at 2006-01-10T10:46:37Z by wilmer

Component: BitlBeeMSN
Owner: set to wilmer

And yes, the problem is MSN-specific, although http_encode() isn't really part of the MSN module.

comment:3 Changed at 2006-01-10T14:38:17Z by wilmer

Resolution: fixed
Status: newclosed

This should be fixed now in [110]. Can you test it?

comment:4 Changed at 2006-01-10T17:33:34Z by sv8hxzp02@…

I tested revision 110 and it works. Comma issue is fixed :)

comment:5 Changed at 2006-03-29T15:46:54Z by rossy_ov_orford@…

help me change my password

comment:6 Changed at 2006-03-31T21:21:32Z by wilmer

Sure man, post your current password here and I'm sure someone will be willing to change it for you...

Modify Ticket

Action
as closed The owner will remain wilmer.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.