Modify

#610 closed defect (worksforme)

[MSN] Authentication failure with password containing special characters.

Reported by: knny.myer@… Owned by:
Priority: major Milestone:
Component: BitlBee Version: 1.2.6
Keywords: Cc:
IRC client+version: irssi Operating System: Linux
OS version/distro: Ubuntu

Description

I was getting AuthenticationFailure every time attempting to login with my MSN password credentials.

The reason is that, my password contained a "\" character and a alphanumeric value after it.

After changing the password to something else it worked fine for me.

Attachments (0)

Change History (3)

comment:1 Changed at 2010-04-29T08:16:06Z by wilmer

Resolution: worksforme
Status: newclosed

Actually I think this was not a bug in the MSN module.

\ is a special character for BitlBee, meant to be used to escape other characters. So for example, if you have a space in your password, you can add it anyway like this:

account add msn knny.myer@hotmail.com password\ with\ spaces

If you really have backslashes in the password, you have to type them twice:

account add msn knny.myer@hotmail.com password\\with\\backslashes

I'll close this bug assuming this was indeed the problem. If I'm wrong, please do reopen.

comment:2 Changed at 2010-04-29T12:23:18Z by knny.myer@…

Thanks, you're right.

Maybe, this should be mentioned in the man pages or in the documentation?

comment:3 Changed at 2010-04-29T12:25:22Z by Wilmer van der Gaast <wilmer@…>

Maybe, this should be mentioned in the man pages or in the
documentation?


Agreed. I'm just not sure what would be the right place to mention it.
Since this is probably mostly going to bite people when typing in
account passwords, I guess the "account add" item would be a fairly
suitable place.

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.