Modify

#470 closed defect (fixed)

Unwanted echos in Jabber group chats

Reported by: paul.t.hinze@… Owned by: wilmer
Priority: normal Milestone:
Component: Jabber Version: devel
Keywords: groupchat Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro:

Description

Steps to reproduce:

  • connect to a jabber account with username (mine is on an openfire jabber server)
  • ensure that my username does not exist in blist
  • ensure that a multi user chat is defined with chat add
  • join a multi-user chat with /join &groupchatname
  • say 'hello world'
  • the following is displayed:
      <username> hello world 
      <username_> hello world
    
  • go back to &bitlbee and type 'blist all'
  • username_ is listed as Offline for the jabber account
  • if you type "remove username_", duplicate messages no longer show up in &groupchatname but now any messages typed by username cause the following message in &bitlbee:
    jabber(username@chatserver.com) - Message from/to conversation username@chatserver@0xa09b8d8 (unknown conv/user): hello world
    

Attachments (1)

jabber_groupchat_ignore_echo.patch (612 bytes) - added by paul.t.hinze@… at 2008-12-23T19:53:54Z.
Patch that fixes the described problem.

Download all attachments as: .zip

Change History (7)

comment:1 Changed at 2008-12-23T17:39:16Z by paul.t.hinze@…

Here's some xml console output from the group chat:

11:35 <xmlconsole> TX: <message type="groupchat" to="GROUPCHATNAME@conference.SERVERNAME"><body>blist</body></message>
11:35 <xmlconsole> RX: <message type="groupchat" to="phinze@SERVERNAME/BitlBee" 
                   from="GROUPCHATNAME@conference.SERVERNAME/phinze"><body>blist</body></message>
11:35 <xmlconsole> TX: <message type="groupchat" to="GROUPCHATNAME@conference.SERVERNAME"><body>whoops</body></message>
11:35 <xmlconsole> RX: <message type="groupchat" to="phinze@SERVERNAME/BitlBee" 
                   from="GROUPCHATNAME@conference.SERVERNAME/phinze"><body>whoops</body></message>

Output in &GROUPCHATNAME:

11:35 < phinze> blist
11:35 < phinze_> blist
11:35 < phinze> whoops
11:35 < phinze_> whoops

Changed at 2008-12-23T19:53:54Z by paul.t.hinze@…

Patch that fixes the described problem.

comment:2 Changed at 2008-12-23T19:54:57Z by paul.t.hinze@…

After debugging for awhile, I think I've figured out how to fix this. Please see the attached patch and let me know if this is the right idea.

comment:3 Changed at 2010-03-14T16:13:43Z by wilmer

Hello,

My apologies for not responding at all to this for a long time. :-(

I'm worried that your patch is just hiding a real bug under the carpet. IIRC this is already done elsewhere, so I'm just wondering how the messages are still getting through, and more specifically, where the phinze_ comes from at all.

Are you still seeing this problem? Is this with an anonymous or non-anonymous room?

comment:4 Changed at 2010-03-15T21:24:54Z by paul.t.hinze@…

No worries, wilmer. :)

I actually don't think I've seen this problem on trunk for a while now. You can close this ticket for now and I can re-open or file a new one if I see this behavior again. Thanks.

comment:5 Changed at 2010-03-15T22:04:30Z by wilmer

Resolution: fixed
Status: newclosed

Ok, I'm not going to complain about that. :-)

comment:6 Changed at 2013-02-12T06:17:28Z by Gillingham@…

This is currently appearing for me on 3.2+20130115+devel+969-1. and has since 3.0.4

Modify Ticket

Action
as closed The owner will remain wilmer.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.