Modify

#401 closed defect (fixed)

Jabber Resources

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: Jabber Version: 1.2
Keywords: Cc:
IRC client+version: irssi Operating System: Linux
OS version/distro: Debian

Description

Bitlbee bases the away status on one resource (the first one bitlbee sees), so if they connect using another resource and are active, the away status does not change. Sometimes they may even appear as 'offline'. The only way to honor the correct resource is to reconnect to the jabber server.

Attachments (0)

Change History (8)

comment:1 Changed at 2008-04-15T17:11:01Z by Wilmer van der Gaast <wilmer@…>

And you're really using 1.2? Older versions (with the old Jabber module) had problems like this a lot, but 1.2 should deal with multiple resources properly.

comment:2 Changed at 2008-04-15T17:49:10Z by anonymous

I'm actually using the latest bzr but I only recently switched to that. This has been an issue for as long as I can remember. The latest bzr did seem to improve the issue a bit but not completely.

comment:3 Changed at 2008-06-14T16:07:43Z by wilmer

Milestone: 1.2.1

comment:4 Changed at 2008-06-15T17:38:16Z by wilmer

The improvement is actually pretty huge since the old Jabber module didn't handle multiple resources *at all* while now BitlBee always shows information of the resource with the highest priority. And with the "info" command, you can get information on the others.

I have seen an issue with someone never going offline though, and this seems to be reproducible. Will generate some XML dumps.

comment:5 Changed at 2008-06-20T09:27:32Z by wilmer

I wonder if you're having this problem with buddies on the Google Talk network? I just saw this problem again and fortunately had xmlconsole logs this time, and grepping for this JID didn't show me any on-line announcements. When the person went off- and back online, everything was fine again, but it did give me this message:

10:12:18 @ root| jabber(wilmer@…) - Warning: Received presence information from

unknown JID: example@…/AdiumD3E6C970

I'm afraid you're not looking at this bug anymore, but if you are, can you tell me if this is indeed on Google Talk and if you also get these msgs?

comment:6 Changed at 2008-06-21T23:56:47Z by wilmer

Milestone: 1.2.1

Removing the milestone since the only case of this bug happening I know of is not a bug in BitlBee. If you can give another example, please do.

comment:7 Changed at 2008-07-01T16:14:55Z by anonymous

Yes, it was indeed on Google Talk.

comment:8 Changed at 2008-07-01T16:31:29Z by wilmer

Resolution: fixed
Status: newclosed

Okay, thanks for confirming that! I'll close this bug, since I can't think of any way where this could still be broken in BitlBee, besides misinterpreting received presence stanzas.

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.