#354 closed defect (fixed)

Can't join jabber chatroom with 1.1.1dev

Reported by:… Owned by:
Priority: normal Milestone:
Component: Jabber Version: 1.1.1dev
Keywords: Cc:
IRC client+version: Xchat 2.8.3c Windows Operating System: Public server
OS version/distro: Ubuntu Gutsy


trying to connect into a jabber chatroom for work but can't... really odd behavior here...

<tekkub> join_chat 1
  ** Nothing happens **
<tekkub> join_chat 1
<root> Channel already exists: &general-discussion
/join &general-discussion
* &general-discussion :No such nick

The same happens both on my own hosted server and on Connecting thru jabber with ssh turned on.

Attachments (0)

Change History (17)

comment:1 Changed at 2008-02-02T12:54:33Z by wilmer

The same thing happens here. That conference server just doesn't respond. Can you join it using a different client?

comment:2 Changed at 2008-02-02T12:58:01Z by wilmer

Milestone: 1.2

Same thing happens with Gajim here. Also, after a few minutes my Jabber server does respond:

12:52:17  xmlconsol| TX: <presence to="" id="BeeCQnLinZyRINea0003c"><x 
12:55:26  xmlconsol| RX: <presence from="" to="" 
                     type="error" id="BeeCQnLinZyRINea0003c"><x xmlns=""/><error code="404" 
                     type="cancel"><remote-server-not-found xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></presence>

Looks like this is not a BitlBee bug. Except that it should cache packets a bit longer, because it failed to handle this error response, it forgot what it is about. Will fix that part.

comment:3 Changed at 2008-02-02T22:36:01Z by anonymous

The server's not responding because it's not set to, it's an internal work server and all... supposed to be a private server.

I'll see if I can reproduce this on a public server, if not I can prolly get my boss to make you an account to test with.

comment:4 Changed at 2008-02-02T22:40:58Z by wilmer

Or maybe you can enable xmlconsole? If you add a buddy "xmlconsole" (no @ or whatever) to your Jabber contact list you'll get an XML dump like what I pasted here, so you can see what you received exactly.

comment:5 Changed at 2008-02-02T22:48:31Z by anonymous

<xmlconsole> TX: <presence to="" id="BeeClvEboiSY/Tg50007c"><x xmlns=""/></presence>

That was it, nothing else ><

comment:6 Changed at 2008-02-03T13:57:47Z by wilmer

Milestone: 1.2

If that's all, then I guess the server somehow still doesn't want to accept your connection. Maybe the room is password-protected?

Anyway, I changed the garbage collection code of cached packets to keep packets around a bit longer. This way, the error reported by your Jabber server after a few minutes will be handled properly. I'll remove the milestone now and keep the bug open a bit longer so we can see what's going on here.

comment:7 Changed at 2008-02-03T20:40:26Z by anonymous

I don't believe there is a channel password, since he already restricts connections to accounts on the server. I'll see if I can get console output from Miranda (which can open the channels)... perhaps it will help.

comment:8 Changed at 2008-02-03T23:16:21Z by wilmer

Resolution: fixed
Status: newclosed

Resolved via e-mail.

comment:9 Changed at 2008-02-05T23:06:42Z by anonymous

Resolution: fixed
Status: closedreopened

Could someone post the solution to this problem? i'm getting the exact same issue and I can't figure out what's wrong.


comment:10 Changed at 2008-02-05T23:09:07Z by anonymous

My issue was that I forgot the "@conference." in the room name. I'm an idiot ><

comment:11 Changed at 2008-02-05T23:12:15Z by anonymous

Sorry, I hate to be retarded, but what "@conference"? could you give an example of what you typed wrong and what was correct? I really don't want to end up just typing the wrong thing :P


comment:12 Changed at 2008-02-05T23:14:35Z by anonymous

general-discussion@… ---> general-discussion@…

comment:13 Changed at 2008-02-05T23:20:21Z by wilmer

Which room are you trying to join? Does xmlconsole show the same thing?

comment:14 Changed at 2008-02-05T23:21:14Z by anonymous

Ah you're a legend! (and I am a numpty) Thanks so much

problem solved >_> <_<

comment:15 Changed at 2008-02-05T23:26:38Z by anonymous

Hey wilmer, I know you said that there was something like a 4-min timeout before the server sends back an error... maybe bitlbee should have a shorter timeout where it warns the user that the room may not exist... it would certainly help over the silent failure we get right now... something like:

<user> join_chat .... *5-sec delay* <root> no response from server, the room may not exist. Did you spell the chat room name correctly? Many servers host their rooms at <room>@conference.<server>

comment:16 Changed at 2008-02-05T23:27:23Z by anonymous

damnit, stupid trac formatting always buggers up on me, and I can't go back and edit *stabs trac*

comment:17 Changed at 2008-02-10T15:30:03Z by wilmer

Resolution: fixed
Status: reopenedclosed

Hmm, could do that, but I'm not sure how useful a log message exactly one minute after trying to join would be. Although right now the join_chat command does not generate any output at all, maybe that's bad. At least some "feedback" would hopefully convince the user that BitlBee is still alive.

Or what I can do is make it echo a "be patient, grasshopper" message if the user re-enters the same join_chat command. :-)

Modify Ticket

as closed The ticket will remain with no owner.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.