Modify

#1219 closed defect (fixed)

SIPE group chats do not work

Reported by: moo.bitlbee.z.edmcman@… Owned by:
Priority: normal Milestone:
Component: Purple Version: 3.4
Keywords: sipe Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro:

Description

I am using the pidgin-sipe plugin to connect to SIPE. It works great for private messages. Unfortunately, I can't get it to join a group chat. If I add the channel using chat add, and then /join it, nothing happens. Joining group chats works fine using pidgin.

Attachments (0)

Change History (6)

comment:1 Changed at 2015-11-26T05:02:09Z by dx

Not sure if directly relevant but try with latest git, particularly with this commit:

https://github.com/bitlbee/bitlbee/commit/a3019499665384a3dcbbc11016d256e6d4dcd26c

comment:2 Changed at 2016-05-12T08:58:53Z by admin@…

Hello!

I tried to reproduce your problem and can confirm this behavior.

With Pidgin 2.10.12 (Windows) and prpl-sipe 1.21.0 i can retrieve a roomlist and join the room.

http://i.imgur.com/YbnONhU.png http://i.imgur.com/3AN21br.png

On bitlbee-libpurple 3.4.2+20160506+master+27-g4fe91a1-git and pidgin-sipe (version 1.21.0-1 as well) the client connects correctly and I can use 1-to-1 chats. Unfortunately the groupchat does not work:

Steps to reproduce:

The ma-chan uri is taken from pidgins roomlist.

10:32 <@hs> channel list
10:32 <@root>  0. &bitlbee, control channel (joined)
10:32 <@root> End of channel list

10:33 <@hs> chat add sipe ma-chan://example.lan/f79ec811-b1e3-4156-983b-cabe0bf37aad #ops
10:33 <@root> Chatroom successfully added.

10:33 <@hs> channel list
10:33 <@root>  0. &bitlbee, control channel (joined)
10:33 <@root>  1. #ops, chat channel
10:33 <@root> End of channel list

10:34 <@hs> channel 1 set
10:34 <@root> account = `sipe'
10:34 <@root> auto_join = `false'
10:34 <@root> chat_type = `room'
10:34 <@root> nick is empty
10:34 <@root> room = `ma-chan://example.lan/f79ec811-b1e3-4156-983b-cabe0bf37aad'
10:34 <@root> translate_to_nicks = `true'
10:34 <@root> type = `chat'

When entering /join #ops the following is shown in &bitlbee but the channel is not entered:
10:35 <@root> sipe - Creating new conversation: (id=0x7f3f19581030,handle=ma-chan://example.lan/f79ec811-b1e3-4156-983b-cabe0bf37aad)

When starting bitlbee in debug mode I do not see any messages regarding this problem. Unfortunately I do not know C but I assume that the error is related to that the sipe-plugin asks for an "uri" parameter instead of a "room" parameter which cannot be set in bitlbee (probably in https://github.com/bitlbee/bitlbee/blob/master/protocols/purple/purple.c#L686 ?). There is a github mirror of the sipe plugin; the uri parameter seems to be located here: https://github.com/tieto/sipe/blob/launchpad/src/core/sipe-groupchat.c#L1207

For reference the join chat window on XMPP: http://i.imgur.com/ndp0Wn5.png

Thank you for your efforts and thanks for your help!

Cheers Hannes

comment:3 Changed at 2016-05-15T01:52:55Z by dx

How about "chat add sipe Ops #ops"? The plugin seems to do a name lookup internally.

comment:4 Changed at 2016-05-15T11:22:47Z by admin@…

Hello dx!

Thanks for the reply. I will be back in my office on tuesday and will try this out then.

Have a nice weekend :)

Cheers Hannes

comment:5 in reply to:  3 Changed at 2016-05-17T08:30:53Z by admin@…

Replying to dx:

How about "chat add sipe Ops #ops"? The plugin seems to do a name lookup internally.

Hello! Unfortunately it didn't change anything. :(

9:54:54 AM) herbert: channel list
(9:54:54 AM) root:  0. &bitlbee, control channel (joined)
(9:54:54 AM) root: End of channel list

(9:55:56 AM) herbert: chat add sipe Ops #ops
(9:55:56 AM) root: Chatroom successfully added.

(9:56:02 AM) herbert: channel list
(9:56:02 AM) root:  0. &bitlbee, control channel (joined)
(9:56:02 AM) root:  1. #ops, chat channel
(9:56:02 AM) root: End of channel list

(9:56:06 AM) herbert: channel 1 set
(9:56:06 AM) root: account = `sipe'
(9:56:06 AM) root: auto_join = `false'
(9:56:06 AM) root: chat_type = `room'
(9:56:06 AM) root: nick is empty
(9:56:06 AM) root: room = `Ops'
(9:56:06 AM) root: translate_to_nicks = `true'
(9:56:06 AM) root: type = `chat'

Using "/join #ops":
(9:56:14 AM) root: sipe - Creating new conversation: (id=0x7f3f19601b60,handle=Ops)
but no window opens.

In addition i tried channel 1 set auto_join true which opened a channel window on reconnect with root in it:

(10:04:35 AM) root has changed the topic to: BitlBee groupchat: "Ops". Please keep in mind that root-commands won't work here. Have fun!

but it doesn't seem to actually connect to the room :-(

Thanks for your help!

Cheers Hannes

comment:6 Changed at 2016-12-27T00:46:53Z by dx

Resolution: fixed
Status: newclosed

This is fixed by 1882b70

This adds a purple_uri setting, so if you know the uri you can do

channel #whatever set purple_uri ma-chan://whatever

Additionally, when using the recently added chat list command (chat list sipe, chat add sipe !1 #whatever), that setting will be populated when joining the channel the first time.

I got myself a local skype for business server to confirm that it works (That was painful to set up. Too enterprise for me, and too many potential points of failure during setup. But at least it was free, microsoft provides 180 day trials for everything)

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.