Modify

#118 closed defect (duplicate)

bitlbee as irc service

Reported by: #66 Owned by:
Priority: normal Milestone:
Component: BitlBee Version: devel
Keywords: Cc:
IRC client+version: Client-independent Operating System: Public server
OS version/distro:

Description

  1. check nickserv/chanserv/memoserv if not, fail to run
  2. register imserv
  3. channels registered by usual way
  4. nicks registered by usual way

for example how I may work with this

we had registered nick GBB (GreatBitlBee :)

Level 1: simple messaging.

register IMuser as GBB avatar :)

/msg imserv account add <protocol> <username|uin> <password> [<server>]

OR

/imserv account add <protocol> <username|uin> <password> [<server>]

account commands: list/add/remove/connect/disconnect/ban/unban

list – user only accounts registered for his nick (owner)

ircop – all add – any registered nick remove – owner connect – owner disconnect – owner ban – ircop

banned account always disconnect and can’t receive ANY owners command except list till unbanned.

Uin|username unique. Impossible create new account with same uin|username.

Work logic 1. after connect u can send/receive messages. Receive from imserv in format: IMserv protocol:contact message Send by

/msg imserv <account> <contact> message

if connect and logout from irc then maybe imserv send messages as memo….

Variant: /msg imserv account main <account>

/msg imserv <contact> message1 /msg imserv <contact> message2 /msg imserv <contact> message3

Level 2: imuser as private irc user; channel as contact-list, im accout – as personal account;

imserv work like botserv

user GBB type command /imserv <account> list /imserv <account> link <contact> <#channel> if contact * - full contact list #channel – owned by GBB :), inviteonly, moderated, “hided” (not listed name)

imserv drop “bot” with nick contact (if busy or registered – modify) on channel bot has “invisible” status

imserv can handle bot status “online” as join, “offline” as leave, away, etc. only private window messages received by imuser and topic change – all users as message.

Level 3 : im account as gate, imuser as normal irc bot :-)

BY IRCOP!

/imserv gate add <gate_name> <protocol> <username|uin> <password> [<server>]

/imserv gate connect <gate_name>

/imserv gate disconnect <gate_name>

/imserv gate del <gate_name>

/imserv gate list

/imserv gate <gate_name> contact add <contact>

/imserv gate <gate_name> contact del <contact>

/imserv gate <gate_name> contact find ......

after add contact may distant contoling “bot” with full range irc commands and "bot" will be banned, kicked controlled etc...

Service control: start/stop/rehash/freeze Start/stop/rehash – usual way. Freeze – work registered accounts, stop register new

Attachments (0)

Change History (2)

comment:1 Changed at 2006-03-15T15:05:44Z by wilmer

Resolution: duplicate
Status: newclosed

Indeed, this is a dupe of #66. Sorry, but I really don't see how this will make BitlBee any better. It could look "cooler" to some people, but not to me, nor any of the other developers.

Since this is not the kind of feature that we could implement in fifteen minutes, we won't consider doing this. But if you can write the patch to implement it yourself, of course you're welcome.

Sorry for sounding a bit rude, but this really doesn't add anything to the BitlBee functionality. It won't allow you to do anything you can't do currently already (except getting rid of one server connection in your IRC client, but that doesn't count as an advantage for me).

comment:2 Changed at 2006-03-15T15:28:06Z by anonymous

Level 1 is theoretically possible. For level 2 and 3, see #66.

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.