Modify

#1112 closed defect (duplicate)

Control interface thinks that I want to accept GTalk contact request when I don't.

Reported by: Burrito Owned by: wilmer
Priority: normal Milestone:
Component: BitlBee Version: 3.2
Keywords: patch Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro: Raspberry Pi, RaspBMC

Description (last modified by dx)

012 [05:34:31] <@root> gmail - New request: The user [spammer name redacted]@gmail.com wants to add you to his/her buddy list. 012 [05:34:31] <@root> You can use the yes/no commands to accept/reject this request. 012 [05:37:00] <@Burrito> no 012 [05:37:00] <@root> gmail - Rejected: The user [spammer name redacted]@gmail.com wants to add you to his/her buddy list. 012 [05:37:01] <@root> gmail - [spammer name redacted]@gmail.com just accepted your authorization request 012 [05:37:01] 19━━▶ Joins: [spammer name redacted] ([spammer name redacted]@gmail.com) 012 [05:37:08] <@Burrito> no I didn't :(

Attachments (1)

presence-fix.patch (467 bytes) - added by kevin8t8 at 2014-01-17T20:24:39Z.

Download all attachments as: .zip

Change History (8)

comment:1 Changed at 2014-01-12T05:51:38Z by Burrito

Dammit, it didn't see my line breaks. Here is a more formal message:

012 [05:34:31] <@root> gmail - New request: The user [spammer name redacted]@gmail.com wants to add you to his/her buddy list.

012 [05:34:31] <@root> You can use the yes/no commands to accept/reject this request.

012 [05:37:00] <@Burrito> no 012 [05:37:00] <@root> gmail - Rejected: The user [spammer name redacted]@gmail.com wants to add you to his/her buddy list.

012 [05:37:01] <@root> gmail - [spammer name redacted]@gmail.com just accepted your authorization request

012 [05:37:01] 19━━▶ Joins: [spammer name redacted] ([spammer name redacted]@gmail.com)

012 [05:37:08] <@Burrito> no I didn't :(

What I expected to happen there was the user never to be added to my contacts list in the first place.

comment:2 in reply to:  1 Changed at 2014-01-12T05:52:41Z by Burrito

Replying to Burrito:

Sorry, I missed out another line break. Should be obvious; after where I said "no".

comment:3 Changed at 2014-01-17T20:24:17Z by kevin8t8

It looks like this is a simple fix. In protocols/jabber/jabber_util.c, jabber_buddy_ask_no() should be sending "unsubscribed" presence back, not "subscribed".

Changed at 2014-01-17T20:24:39Z by kevin8t8

Attachment: presence-fix.patch added

comment:4 Changed at 2014-02-04T04:36:56Z by dx

Description: modified (diff)
Keywords: patch added

comment:5 Changed at 2014-02-04T05:51:29Z by dx

Don't tell the people at ticket #887 (reported two years ago, same issue as this one) that the fix was so trivial, they are going to be mad.

Well actually, someone will have to close that ticket at some point.

comment:6 Changed at 2014-02-08T20:55:54Z by dx

Owner: set to wilmer
Status: newassigned

Sup wilmer! Apply this! Trivial two-character patch!

comment:7 Changed at 2014-03-01T02:10:16Z by dx

Resolution: duplicate
Status: assignedclosed

Patch applied in r1012, thanks!

Marking it as duplicate of #887 because we should have done that before. Or we could do it the other way around. I don't know. Let me know if it matters.

Modify Ticket

Action
as closed The owner will remain wilmer.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.