Modify

#1010 closed defect (notmyfault)

gtalk connections timing out?

Reported by: anonymous Owned by:
Priority: major Milestone:
Component: BitlBee Version: 3.0.6
Keywords: Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro:

Description

When I arrived today, my 'bitlbee' channel in irssi was full of reports of gtalk and gtalk2 (my other gtalk account) trying to reconnect over and over again.

'list accounts' shows that both are 'connecting' and it shows, over and over:

11:25:07 root @: gtalk - Logging in: Connecting 11:25:08 root @: gtalk - Logging in: Connected to server, logging in 11:25:08 root @: gtalk - Logging in: Authentication finished 11:25:08 root @: gtalk2 - Logging in: Connecting 11:25:08 root @: gtalk2 - Logging in: Connected to server, logging in 11:25:08 root @: gtalk2 - Logging in: Authentication finished

and then later

11:27:07 root @: gtalk - Login error: Connection timeout 11:27:07 root @: gtalk - Logging in: Signing off.. 11:27:07 root @: gtalk - Logging in: Reconnecting in 135 seconds.. 11:27:07 root @: gtalk2 - Login error: Connection timeout 11:27:07 root @: gtalk2 - Logging in: Signing off.. 11:27:07 root @: gtalk2 - Logging in: Reconnecting in 135 seconds..

I tried fiddling with the settings. Changed to oauth, turned off tls and turned ssl on (and changed port) - nothing has helped.

I'm able to talk to people however i assume that my connection is just getting reset. It simply stays in the 'connecting' state

Attachments (0)

Change History (11)

comment:1 Changed at 2012-11-12T17:22:19Z by anonymous

same problem running 3.0.5 and FreeBSD 9.0-STABLE. issue persists after an upgrade of all ports. suspect google threw a wrench in the works within the past several hours...

comment:2 Changed at 2012-11-12T17:44:13Z by Wilmer van der Gaast <wilmer@…>

Other clients don't have this problem?

comment:3 Changed at 2012-11-12T17:53:01Z by anonymous

no other clients (yahoo, aol, or msn), exhibit this behavior. monitoring the firewall, nothing shows up as blocked. gtalk gets to "authentication finished", then awhile later "connection timeout." all subsequent attempts at "signing off," and "reconnecting," encounter the same issue.

comment:4 Changed at 2012-11-12T18:10:04Z by wilmer

There might be an SSL problem here. IF you compile your BitlBee against OpenSSL you'll likely have this problem. Not with GnuTLS.

Likely a problem on Google's side so hopefully it'll go away soon.

comment:5 Changed at 2012-11-12T18:20:12Z by wilmer

Resolution: notmyfault
Status: newclosed

comment:6 Changed at 2012-11-12T18:24:44Z by becatlibra@…

i tried installing pidgin and setting up the accounts and the pidgin logs show no connection errors. i can confirm that all the others in this datacenter are not having issues with their gtalk sessions in various clients (pidgin, adium, kopete, etc).

running arch linux and bitlbee 3.0.6-2 (was running 3.0.6-1 earlier, updated to try to fix it). I can confirm that the PKGINFO file is using openssl as a dependency, even though I have bother OpenSSL and GnuTLS installed.

comment:7 Changed at 2012-11-12T18:48:57Z by mrozekma@…

Confirmed that switching from OpenSSL to GnuTLS fixes this

comment:8 Changed at 2012-11-12T21:57:55Z by anonymous

confirmed here as well with FreeBSD. thanks for the help.

comment:9 Changed at 2012-11-13T15:52:00Z by becatlibra@…

for what it's worth, it works now without issue with both openssl and gnutls. guessing google flipped back whatever they did.

comment:10 Changed at 2012-12-03T14:36:25Z by wilmer

Just in case this happens again, I expect that devel,948 will fix it. Once the Twitter JSON changes mature, I plan to do a new release that will include this fix.

comment:11 Changed at 2012-12-03T14:37:05Z by wilmer

I meant changeset:devel,948. Ridiculously simple, really. :-/

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.