Modify

#959 closed defect (worksforme)

oauth not working with --ssl=openssl

Reported by: joseph.hirn@… Owned by:
Priority: minor Milestone:
Component: BitlBee Version: 3.0.5
Keywords: build oauth Cc:
IRC client+version: Client-independent Operating System: Public server
OS version/distro:

Description

Hello.

I had an issue with both the 3.0.4 version in precise repo as well as compiling 3.0.5 from source when using the --ssl=openssl where oauth was not working.

<jhirn> acc list [17:26] [17:27]

<root> 0 (gtalk): jabber, me@…

<root> End of account list

<jhirn> acc 0 set oauth true

<root> Setting `oauth' does not exist.

After changing to --ssl=gnutils, all was working as expected. I don't have a second machine to confirm this on and it may be expected behavior, but I would have expected a warning form the app or configure output.

I also noticed in the make output that it was compiling oauth.c and oauth2.c based on the flag. This makes it obvious it triggers a different build based on --ssl flag but again, it wasn't obvious from the configure output. Thankfully the friendly IRC channel helped me discover this but it really cost me a bit of time, especially since the apt-get version from precise did not have it enabled ( I did not have libgnutils-dev installed when I apt-get installed bitlbee).

Attachments (0)

Change History (14)

comment:1 Changed at 2012-05-16T02:25:56Z by wilmer

And you weren't also using --purple=1 by any chance?

comment:2 Changed at 2012-05-16T13:19:19Z by anonymous

Nope. Ssl option only.

comment:3 Changed at 2012-05-16T14:10:25Z by anonymous

What settings does "ac 0 set" show?

comment:4 in reply to:  3 Changed at 2012-05-16T15:16:47Z by joseph.hirn@…

Replying to anonymous:

What settings does "ac 0 set" show?

It does not show oauth in the options.

help set oauth (going from memory on that exact syntax) would display info about oauth setting but it was not available on any account type when doing "account # set". Thanks.

comment:5 Changed at 2012-05-16T15:18:17Z by anonymous

If you are using precise, or have the ability to install a copy quickly, a simple apt-get install bitlbee should reproduce this. I was able to resovle it by compiling on my own with the proper flags but the problem manifested itself from the basic install case, which should be of greater importance, imo.

comment:6 Changed at 2012-05-16T15:39:58Z by anonymous

Yes, but which settings *does* it show?

You either unknowingly run a BitlBee <3.0.5 or a BitlBee with libpurple, that list will show which one of those two is the case. The oauth setting *always* exists for Jabber accounts.

I don't have access to a gprecise machine unfortunately, but the package is supposed to be the same like the one on Debian Testing which I built myself..

comment:7 Changed at 2012-05-16T18:26:01Z by anonymous

I can confirm I did not apt-get bitlbee-libpurple so unless it comes in as a dependency, I didn't use it.

Here is the configureation flags that worked, provided by someone in irc. If I change --ssl=openssl, I get the symptoms as described.

./configure --prefix=/usr --etcdir=/etc/bitlbee --pidfile=/var/run/bitlbee/bitlbee.pid --ipcsocket=/var/run/bitlbee/bitlbee.sock --systemdsystemunitdir=/usr/lib/systemd/system --ssl=gnutls --strip=0 --otr=plugin --skype=plugin

I would have to uninstall and reinstall to give you the full output from ac 0 set. I can do that tonight but I need my chat client during work hours and I'm too busy enjoying the awesome to tear it down right now.

comment:8 Changed at 2012-05-16T18:38:59Z by wilmer

:-)

I assume you did specificallky install "bitlbee"? I've seen dependencies do weird things and install bitlbee-libpurple when typing just "apt-get install bitlbee-plugin-skype".

One other guess is that you weren't reconnected to the new BitlBee properly.

The oauth setting gets added automatically along with all other settings (like tls). If you really didn't have it with 3.0.5 something very very strange was happening.

comment:9 Changed at 2012-05-16T18:53:38Z by anonymous

Well compile it with --ssl=openssl and try, also try the version in teh precise repo. I can fireup a fresh VM with precise and confirm it wasn't an issue with something already on my machine, but I quite clearly saw it, fixed it, recreated it, and resolved it again by changing between openssl and gnutils. I won't bother opening a ticket otherwise.

comment:10 Changed at 2012-06-03T20:37:08Z by wilmer

Resolution: worksforme
Status: newclosed

Can't reproduce this myself, the SSL module you use technically can't even affect the list of available account settings, so either you indeed accidentally had libpurple on, or something was so horribly wrong that I need more info.

comment:11 Changed at 2012-06-03T20:52:42Z by anonymous

Fair enough. Thx for the help. Realize it's obscure and if the issue arises again the details in this ticket can help them.

Thx for bitlbee.

comment:12 Changed at 2012-06-03T20:54:07Z by wilmer

np :-) My spare time is limited these days so I'm trying to not spend too much time debugging obscure bugs. :-(

comment:14 Changed at 2016-05-10T18:29:47Z by jtmiller@…

Simply installing out of apt lead me to the same problem.

Was following along: https://wiki.bitlbee.org/HowtoGtalk

14:28 <@shmup> acc gtalk set oauth on 14:28 <@root> Setting `oauth' does not exist.

comment:15 in reply to:  14 Changed at 2016-05-10T23:13:43Z by dx

Replying to jtmiller@…:

Simply installing out of apt lead me to the same problem.

Was following along: https://wiki.bitlbee.org/HowtoGtalk

14:28 <@shmup> acc gtalk set oauth on 14:28 <@root> Setting `oauth' does not exist.

It's not the same problem, those builds don't use openssl. Next time open a new ticket or, even better, just ask on irc.

As mentioned in other comments in this ticket, your issue is most likely using bitlbee-libpurple. Libpurple's jabber doesn't have oauth.

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.