Modify

#946 closed defect (fixed)

GET GROUP xxx USERS locks up

Reported by: Elan Ruusamäe <glen@…> Owned by: Miklos Vajna
Priority: normal Milestone:
Component: Skype Version: 3.0.5
Keywords: Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro:

Description

seems if skyped/bitlbee-skype sends GET GROUP xxx USERS command, that queues up all other commands and the command itself timeouts.

i sent SEARCH GROUPS CUSTOM manually via skypeconsole to reproduce this:

2012-04-15 14:34:33: >> SEARCH GROUPS CUSTOM
2012-04-15 14:34:33: << GROUPS 
2012-04-15 14:34:47: >> SEARCH GROUPS CUSTOM
2012-04-15 14:34:47: << GROUPS 
2012-04-15 14:34:49: << GROUP 1162 EXPANDED TRUE
2012-04-15 14:35:21: >> SEARCH GROUPS CUSTOM
2012-04-15 14:35:21: << GROUPS 
2012-04-15 14:35:41: >> SEARCH GROUPS
2012-04-15 14:35:41: << GROUPS 1172, 1171, 1170, 1169, 1168, 1167, 1166, 1165, 1164, 1163, 1162
2012-04-15 14:35:41: >> GET GROUP 1172 DISPLAYNAME
2012-04-15 14:35:41: << GROUP 1172 DISPLAYNAME 
2012-04-15 14:35:41: >> GET GROUP 1172 USERS
2012-04-15 14:36:11: Warning, sending 'GET GROUP 1172 USERS' failed (Skype command timeout).
2012-04-15 14:36:11: >> GET GROUP 1171 DISPLAYNAME
2012-04-15 14:36:11: << GROUP 1171 DISPLAYNAME 
2012-04-15 14:36:11: >> GET GROUP 1171 USERS
2012-04-15 14:36:41: Warning, sending 'GET GROUP 1171 USERS' failed (Skype command timeout).
2012-04-15 14:36:41: >> GET GROUP 1170 DISPLAYNAME
2012-04-15 14:36:42: << GROUP 1170 DISPLAYNAME 
2012-04-15 14:36:42: >> GET GROUP 1170 USERS
2012-04-15 14:37:12: Warning, sending 'GET GROUP 1170 USERS' failed (Skype command timeout).
2012-04-15 14:37:12: >> GET GROUP 1169 DISPLAYNAME
2012-04-15 14:37:12: << GROUP 1169 DISPLAYNAME 
2012-04-15 14:37:12: >> GET GROUP 1169 USERS
2012-04-15 14:37:42: Warning, sending 'GET GROUP 1169 USERS' failed (Skype command timeout).
2012-04-15 14:37:42: >> GET GROUP 1168 DISPLAYNAME
2012-04-15 14:37:42: << GROUP 1168 DISPLAYNAME 
2012-04-15 14:37:42: >> GET GROUP 1168 USERS
2012-04-15 14:38:12: Warning, sending 'GET GROUP 1168 USERS' failed (Skype command timeout).
2012-04-15 14:38:12: >> GET GROUP 1167 DISPLAYNAME
2012-04-15 14:38:12: << GROUP 1167 DISPLAYNAME 
2012-04-15 14:38:12: >> GET GROUP 1167 USERS
2012-04-15 14:38:42: Warning, sending 'GET GROUP 1167 USERS' failed (Skype command timeout).
2012-04-15 14:38:42: >> GET GROUP 1166 DISPLAYNAME
2012-04-15 14:38:42: << GROUP 1166 DISPLAYNAME 
2012-04-15 14:38:42: >> GET GROUP 1166 USERS
2012-04-15 14:39:12: Warning, sending 'GET GROUP 1166 USERS' failed (Skype command timeout).
2012-04-15 14:39:12: >> GET GROUP 1165 DISPLAYNAME
2012-04-15 14:39:12: << GROUP 1165 DISPLAYNAME 
2012-04-15 14:39:12: >> GET GROUP 1165 USERS
2012-04-15 14:39:42: Warning, sending 'GET GROUP 1165 USERS' failed (Skype command timeout).
2012-04-15 14:39:42: >> GET GROUP 1164 DISPLAYNAME
2012-04-15 14:39:42: << GROUP 1164 DISPLAYNAME 
2012-04-15 14:39:42: >> GET GROUP 1164 USERS
2012-04-15 14:40:12: Warning, sending 'GET GROUP 1164 USERS' failed (Skype command timeout).
2012-04-15 14:40:12: >> GET GROUP 1163 DISPLAYNAME
2012-04-15 14:40:12: << GROUP 1163 DISPLAYNAME 
2012-04-15 14:40:12: >> GET GROUP 1163 USERS
2012-04-15 14:40:42: Warning, sending 'GET GROUP 1163 USERS' failed (Skype command timeout).
2012-04-15 14:40:42: >> GET GROUP 1162 DISPLAYNAME
2012-04-15 14:40:42: << GROUP 1162 DISPLAYNAME 
2012-04-15 14:40:42: >> GET GROUP 1162 USERS
2012-04-15 14:41:12: Warning, sending 'GET GROUP 1162 USERS' failed (Skype command timeout).
2012-04-15 14:41:13: >> SEARCH GROUPS CUSTOM
2012-04-15 14:41:13: << GROUPS 
2012-04-15 14:41:13: >> ALTER CHAT #foo/$echo123;7f258ddbb5809f12 SETTOPIC uustopic
2012-04-15 14:41:13: << ALTER CHAT SETTOPIC
2012-04-15 14:41:14: >> SET USERSTATUS OFFLINE
2012-04-15 14:41:15: << CHAT #foo/$echo123;7f258ddbb5809f12 TOPIC newtopic
2012-04-15 14:41:15: << CHAT #foo/$echo123;7f258ddbb5809f12 ACTIVITY_TIMESTAMP 1334490073
2012-04-15 14:41:15: << CHAT #foo/$echo123;7f258ddbb5809f12 FRIENDLYNAME newtopic
2012-04-15 14:41:15: << CHATMESSAGE 1193 STATUS SENDING
2012-04-15 14:41:15: << USERSTATUS OFFLINE
2012-04-15 14:41:15: << USER foo ONLINESTATUS OFFLINE
2012-04-15 14:41:15: << USERSTATUS OFFLINE
2012-04-15 14:41:15: << USER echo123 ONLINESTATUS OFFLINE
2012-04-15 14:41:15: << GROUP 1168 NROFUSERS 1
2012-04-15 14:41:15: << CONNSTATUS OFFLINE

i typed change chat topic ~5 minutes before it got finally sent to skype...

i'm not sure is this problem of Skype4Py api, skype, bitlbee, bitlbee-skype or the x11 protocol Skype4Py uses...

Attachments (0)

Change History (5)

comment:1 Changed at 2012-04-22T21:50:45Z by Miklos Vajna

I can reproduce this and I think this is a Skype bug. As a workaround, we could simply disable reading groups by default, since I guess most users don't really need them anyway, and a separate setting could enable this feature. Does that make sense?

comment:2 Changed at 2012-04-23T07:11:34Z by Elan Ruusamäe <glen@…>

yep. i did it so for myself, seems i forgot to attach patch here.

http://cvs.pld-linux.org/packages/bitlbee/skype-no-groups.patch

it worked fine after that patch (no more extra lags)

comment:3 Changed at 2012-04-23T07:25:28Z by Miklos Vajna

OK, I want to extend it a bit, so a dedicated

account skype set search_groups true

will still enable this code.

comment:5 Changed at 2012-12-31T14:33:02Z by Miklos Vajna

Resolution: fixed
Status: newclosed

This got merged as

acc skype set read_groups true

in r960.

Modify Ticket

Action
as closed The owner will remain Miklos Vajna.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.