Modify

#834 closed enhancement (fixed)

Make IPC socket path configurable at runtime

Reported by: aidalgol@… Owned by:
Priority: wishlist Milestone:
Component: BitlBee Version: 3.0.3
Keywords: IPC socket runtime configuration Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro: Debian wheezy

Description

I am using the Debian (wheezy) package of Bitlbee (3.0.3-1) and I prefer to run it as an unprivileged user. The problem with that is that the path for the IPC socket is only configurable at compile-time, so I always get this error:

Error: Could not remove old IPC socket at /var/run/bitlbee.sock: Permission denied

The problem is not with privileges; it is that I can not tell Bitlbee (at runtime) to put the IPC socket in ~/.bitlbee/

Attachments (0)

Change History (2)

comment:1 Changed at 2011-09-19T19:12:42Z by Wilmer van der Gaast <wilmer@…>

TBH I'm tempted to just kill that IPC socket. Nothing uses it and this error/warning message is a continuous source of confusion... :-/

I'll try to make it optional somehow, in case someone finds a use for it later.

comment:2 Changed at 2011-10-20T03:19:32Z by wilmer

Resolution: fixed
Status: newclosed

changeset:devel,817.

Now gone unless one really requests it.

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.