Modify

#745 closed enhancement (worksforme)

When non-root, can't bind to privledged port

Reported by: caci_ Owned by:
Priority: normal Milestone:
Component: BitlBee Version: 3.0.1
Keywords: Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro:

Description

When running as a non-root user, Bitlbee is unable to open a priviledged port (<1024), because it drops priviledges prior to listening.

Fix: Open the port first, then drop priviledges, like other daemons do.

Is that possible to implement without large changes?

Attachments (0)

Change History (2)

comment:1 Changed at 2011-01-15T17:25:53Z by caci_

Please disregard, was traced to a bug in the startup script.

NOT A BUG IN BITLBEE.

comment:2 Changed at 2011-01-15T17:31:40Z by wilmer

Resolution: worksforme
Status: newclosed

Ah, thanks for updating the bug tracker then. Much appreciated.

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.