Modify

#727 closed defect (fixed)

msn login server error

Reported by: flux@… Owned by:
Priority: normal Milestone:
Component: BitlBee Version: 3.0
Keywords: Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro:

Description

I'm running the current stable release (3.0), and recently I've been having problems with logging into MSN messenger. The login itself happens fine, and my "buddies" are able to message me and I can reply. However, all of my contacts are constantly offline. I even tested my own visibility by having myself as a contact in my list, and I even appear offline to myself. I do not appear offline to my contacts though, as they claim I show up as "online". When logging in, there is a single error message of the following:

msn - Login error: Error reported by MSN server: ADL/RML command with invalid modification

I know that it isn't due to bitlbee itself, as it was working fine for quite a while and I've only been experiencing the problem for a matter of a few days.

I tried searching the web about this, and the only thing that looked relevant was something for pidgin and how the MSN servers have recently changed their certificates (http://developer.pidgin.im/ticket/12906), but without providing the middle layer certificates, so there's no automated way to update and/or verify the new certificates while the older certificates fail because they no longer match. I don't know if this is what's affecting the bitlbee login, or if it is how I could fix it (I don't know where bitlbee stores/caches the certificate files, so I can't do manual testing to see if changing the certificate for the MSN servers fixes it).

I'm also not sure if this is related to bug 712 since there's no information on a reported login error mentioned, while I'm seeing the error reported.

Please advise me on anything I can do to test/fix this, or let me know what further information you would need that would be helpful in resolving the issue. Thanks.

Attachments (0)

Change History (5)

comment:1 Changed at 2010-11-22T14:15:08Z by Wilmer van der Gaast <wilmer@…>

testing.bitlbee.org has a fix for what I believe is the cause of this problem. Feel like verifying that?

comment:2 Changed at 2010-11-22T14:54:21Z by flux@…

If you could tell me the specific version testing.bitlbee.org is running I can test it locally. I'd like to keep my account data local if possible, rather than having to migrate back and forth etc. Or if you can specify a specific commit, I can always test the specific patch as well.

comment:3 Changed at 2010-11-22T14:58:02Z by Wilmer van der Gaast <wilmer@…>

Fair enough. Just use what is in head now. The nightly builds (if you use Debian/Ubuntu) will also have it.

comment:4 Changed at 2010-11-29T16:27:10Z by flux@…

I'm sorry it took me a while to get back to you about this. I got really busy with work, and I didn't have a chance to test it until tonight, but being as there was a new release I tested with that. It works fine. You can probably close this bug, and thanks!

comment:5 Changed at 2010-12-04T12:24:57Z by wilmer

Resolution: fixed
Status: newclosed

Ok :-)

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.