Modify

#550 closed defect (fixed)

ICQ (re)connect stalls in "connecting" state

Reported by: bitlbee@… Owned by: Jelmer Vernooij
Priority: normal Milestone:
Component: OSCAR Version: 1.2.4
Keywords: Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro: Debian testing

Description

Sometimes I notice ICQ isn't online and hanging in the "connecting" state. This seems to happen after an ICQ disconnect, like so (ICQ nr obfuscated):

1211 060110 <@ root> oscar - Error: Disconnected. 1211 060110 <@ root> oscar - Signing off.. 1211 060110 <@ root> oscar - Flushed 1 unanswered question(s) for this connection. 1211 060110 <@ root> oscar - Reconnecting in 5 seconds.. 1211 060115 <@ root> oscar - Logging in: Signon: 123456 1211 060115 <@ root> oscar - Logging in: Connection established, cookie sent 1211 060116 <@ root> oscar - Couldn't log in: SNAC threw error: Busted SNAC payload 1211 060116 <@ root> oscar - Logging in: Logged in 1211 061830 <@ root> oscar - Error: Disconnected. 1211 061830 <@ root> oscar - Signing off.. 1211 061830 <@ root> oscar - Reconnecting in 5 seconds.. 1211 061835 <@ root> oscar - Logging in: Signon: 123456 1211 061835 <@ root> oscar - Logging in: Connection established, cookie sent 1211 061836 <@ root> oscar - Couldn't log in: SNAC threw error: Busted SNAC payload

After that, the connection hangs on "connecting":

1211 153356 <@ Vinz> account list 1211 153356 <@ root> 0. oscar, 123456 (connecting)

Dis- and reconnecting solves the issue for a while:

1211 153401 <@ Vinz> account off 0 1211 153401 <@ root> oscar - Logging in: Signing off.. 1211 153404 <@ Vinz> account on 0 1211 153404 <@ root> oscar - Logging in: Signon: 123456 1211 153404 <@ root> oscar - Logging in: Connection established, cookie sent 1211 153405 <@ root> oscar - Couldn't log in: SNAC threw error: Busted SNAC payload 1211 153405 <@ root> oscar - Logging in: Logged in

This happens every few weeks or so.

Attachments (0)

Change History (6)

comment:1 Changed at 2009-12-11T15:01:19Z by bitlbee@…

Oops. Sorry for the formatting. It's stil somewhat readable though.

comment:2 Changed at 2010-03-12T22:42:20Z by anonymous

i can confirm this

comment:3 Changed at 2010-10-29T08:07:31Z by anonymous

This happens to me on AIM Oscar too.

comment:4 Changed at 2010-11-24T09:45:35Z by someone

10:42 <@myusername> account on 0 10:42 <@root> oscar - Logging in: Signon: xxxxxx 10:42 <@root> oscar - Couldn't log in: Disconnected. 10:42 <@root> oscar - Logging in: Signing off.. 10:42 <@root> oscar - Logging in: Reconnecting in 900 seconds..

hi , since a few days i cant login to my oscar account. if i use another messenger it works fine ... so my ICQ account is working without problems

i hope it will be fixed soon.

comment:5 Changed at 2010-11-24T10:50:33Z by Wilmer van der Gaast <wilmer@…>

Already known for a while. See the website.

comment:6 Changed at 2010-11-24T22:36:13Z by wilmer

Resolution: fixed
Status: newclosed

changeset:devel,726 fixes this BTW.

Modify Ticket

Action
as closed The owner will remain Jelmer Vernooij.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.