#517 closed defect (obsolete)

unknown handle even though user is on list

Reported by: baa@… Owned by: Jelmer Vernooij
Priority: major Milestone:
Component: OSCAR Version: 1.0.1
Keywords: Cc:
IRC client+version: Irssi Operating System: Linux
OS version/distro: Gentoo


Probably this problem occurs since ICQ changed to the new protocol, because this was around the time, when the error appeared the first time to me.

A user, which is already on my contact list, sends me a message and instead of a new query window the message appears in the status window: "<@root> ICQ - Message from unknown handle *: "... This user is not shown as online in the control channel, even if he is online. And whenever I send a message to this users, I get "... user is offline" and the message never arrives the user.

When I noticed this problem first, I thought it depends on the users ICQ version/client. But later the problem occurred again: My aunt got a new PC and I installed her a new ICQ version. When I connected to my bitlbee, to do all the authorization stuff for the new ICQ number, the error appeared again, even though the communication with her old ICQ version worked well.

So I thought the problem must depend on bitlbee, and I tried to reproduce the problem and created a dump file with ethereal. I uninstalled the "old" icq version on my laptop and installed the "new" ICQ version (both was icq lite 5.0). With the old version communications between ICQ and Bitlbee worked well. With the new version the same error appeared.

The dump file contains the following:

  1. Message from Bitlbee to ICQ5: "test vom bitlbee"
  2. Message from ICQ5 to Bitlbee: "nochma was vom icq"
  3. Message from Bitlbee to ICQ5: "ich kann dich lesen aber du mich nicht"

Short summary: Some icq users appear offline in bitlbee, even if they are online. When they send me a msg, the msg appears as unknown handle. Answering this msg does not work, because the msg never arrives at the icq user.

Attachments (0)

Change History (6)

comment:1 Changed at 2006-06-12T07:44:06Z by baa@…

Yesterday I had the same problem with a bitlbee user. I added him to my list (add 0 icqnr* nickname*) and then he appeared offline to me, though he was online. When he sent me a msg, it was shown in the control channel ("<@root> ICQ - Message from unknown handle icqnr*:"...). I did not tried to send him a msg to see whether he can read my msgs, since it seemed to be the same problem. I also dont know what bitlbee version he uses and so on. If those informations are required, you can tell me (Alita`) in irc.

comment:2 Changed at 2006-07-08T11:29:31Z by baa@…

The as unknown handle appearing nicks which i added with bitlbee appear in ICQ2Go instead with an Icq-Flower-Icon with an Aol Messenger Icon and instead of a nickname in Icq2Go Flashversion with $icqnumber@… and in Icq2Go Javaversion with "pleaseupgrade000".

Now there are already 5 People (with increasing tendency), wich I cannot communicate with. One of them uses bitlbee, an other some miranda-version and the others are icq-users.

And it seems, the try to communicate with them with an other (new) icq number via bitlbee failed. They still appear offline to me (even they arent) and my messages dont arrive them. :(

comment:3 Changed at 2006-07-08T11:43:39Z by baa@…

sorry for one comment more, but there are some news:

when i was testing my bitlbee with the newer icq account, i had my older icq account running in icq2go. there i deleted the strange appearing accounts and added the one with the bitlbee (the only reachable person from these buggy ones) from within icq2go, which asked for authorisation. when he accepted the authorisation, he was on my icq list. then i started my older icq account in bitlbee again and now he was online and communication works!

maybe this bug has something to do with authorisation?

comment:4 Changed at 2006-07-10T11:58:01Z by baa@…

I hope this is my last comment, which can help to solve the problem...

I told this news already to wilmer via IRC, but to remember everything, I will write it down here again.

I told already about the fact that I readded all buggy contacts via icq2go. With the bitlbee user and his authorization request this worked fine. Since today I know that it worked also for the Miranda-like Client without request.

I remember this problem concerned only people which I added via bitlbee. So today I had the same problem: adding a user, who is online -> <@root> User' added to your contact list as XXX' (while x were numbers and X chars) -> but he did not appear as online. So I set account off, started icq2go, found the newly added account as "pleaseupgrade000", deleted it, added the user new, was waiting for authorization, quitted icq2go and set account on. Now the user was online!

So it really has to do something with adding users via bitlbee.

two quotations from my query to wilmer: <wilmer> maybe bitlbee requests the authorization the wrong way <wilmer> now we have to see the difference between adding buddies from bitlbee or other clients

comment:5 Changed at 2006-10-22T13:51:08Z by wilmer

Component: BitlBeeOSCAR
Owner: set to Jelmer Vernooij

comment:6 Changed at 2012-03-25T23:37:40Z by wilmer

Resolution: obsolete
Status: newclosed

Sorry for never really following up to this.. The OSCAR module is the most poorly maintained of all because its code is the most crappy, and the protocol itself is also barely worth working on for years already with the AIM/ICQ market share being the way itis.

Modify Ticket

as closed The owner will remain Jelmer Vernooij.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.