Modify

#379 closed defect (worksforme)

Unable to login with gmail account

Reported by: renchap@… Owned by:
Priority: major Milestone:
Component: Jabber Version: 1.2
Keywords: Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro: Gentoo amd64

Description

I cant login to my gtalk account using bitlbee :

12:53:32 @      renchap | account add jabber renchap@gmail.com password
12:53:32 @         root |  Account successfully added
12:53:35 @      renchap | account list
12:53:35 @          root  0. msn, renchap@cocoa-x.com (connected)
12:53:35 @          root  1. oscar, renchapav (connected)
12:53:35 @          root  2. yahoo, renchap13 (connected)
12:53:35 @          root  3. jabber, renchap@jabber.org (connected)
12:53:35 @         root |   4. oscar, 43670193 (connected)
12:53:35 @          root  5. jabber, renchap@gmail.com/bitlbee
12:53:35 @         root |  End of account list
12:53:40 @      renchap | account on 5
12:53:40 @          root jabber(renchap@gmail.com) - Logging in: Connecting
12:53:40 @          root jabber(renchap@gmail.com) - Logging in: Connected to server, logging in
12:53:40 @          root jabber(renchap@gmail.com) - Logging in: Converting stream to TLS
12:54:00 @          root jabber(renchap@gmail.com) - Logging in: Connected to server, logging in
12:54:00 @          root jabber(renchap@gmail.com) - Couldn't log in: Short write() to server
12:54:00 @          root jabber(renchap@gmail.com) - Logging in: Signing off..
12:54:00 @          root jabber(renchap@gmail.com) - Logging in: Reconnecting in 300 seconds..

bitlbee server : jaina.renchap.com:6668 i have tried with another jabber account, does not work :(

Attachments (0)

Change History (6)

comment:1 Changed at 2008-03-22T12:01:34Z by wilmer

Which SSL module are you using?

comment:2 Changed at 2008-03-23T10:45:56Z by renchap@…

How can i see this ?

comment:3 Changed at 2008-03-23T15:05:24Z by wilmer

If you have access to the machine that runs BitlBee, you can use ldd or check Makefile.settings in the build tree. Otherwise, there's no way to see this.

I assume that server's running Gentoo? There are known issues with BitlBee and Gentoo's version of OpenSSL.

comment:4 Changed at 2008-03-23T18:26:41Z by renchap@…

ldd /usr/sbin/bitlbee
        linux-vdso.so.1 =>  (0x00007fff1f3fd000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x00002b1c8ba40000)
        libdl.so.2 => /lib/libdl.so.2 (0x00002b1c8bc44000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00002b1c8be48000)
        libssl.so.0.9.8 => /usr/lib/libssl.so.0.9.8 (0x00002b1c8c10f000)
        libcrypto.so.0.9.8 => /usr/lib/libcrypto.so.0.9.8 (0x00002b1c8c35a000)
        libc.so.6 => /lib/libc.so.6 (0x00002b1c8c6d1000)
        /lib64/ld-linux-x86-64.so.2 (0x00002b1c8b814000)

It is bitlbee 1.2 gentoo package, you can find it here : http://gentoo-portage.com/AJAX/Ebuild/62731/View

Compiled with the following use flags : [code] [ebuild R ] net-im/bitlbee-1.2 USE="ipv6 jabber msn oscar ssl yahoo -debug -gnutls -nss -xinetd" 0 kB code

I have enabled the gnutls use flag, and it works now. Maybe you (or i) should open a bug in gentoo bugtracker.

Thanks a lot :)

comment:5 Changed at 2008-03-23T21:23:56Z by wilmer

Resolution: worksforme
Status: newclosed

That could be nice. There may be a problem in BitlBee as well, although so far this hasn't showed up on any other system than Gentoo, even though my Debian testing box has exactly the same (upstream) version of OpenSSL.

So if you could open a bug with the port maintainer, that'd be great. Is it possible to Cc me on it even though I don't have an account on their BTS?

comment:6 Changed at 2008-12-21T21:30:24Z by paul.t.hinze@…

I am getting the short write error described above on a copy of bitlbee I compiled from scratch from the development bzr branch with openssl on an Ubuntu 8.10 machine. I'm running the bitlbee server locally.

Here is the error showing up:

15:27 <@phinze> account set 2
15:27 <@root> auto_connect = `1'
15:27 <@root> auto_reconnect = `true'
15:27 <@root> password is empty
15:27 <@root> username = `paul.t.hinze@gmail.com'
15:27 <@root> port = `5223'
15:27 <@root> priority = `0'
15:27 <@root> resource = `BitlBee'
15:27 <@root> resource_select = `priority'
15:27 <@root> server = `talk.google.com'
15:27 <@root> ssl = `true'
15:27 <@root> tls = `true'
15:27 <@root> xmlconsole = `false'
15:27 <@phinze> account on 2
15:27 <@root> jabber(paul.t.hinze@gmail.com) - Logging in: Connecting
15:27 <@root> jabber(paul.t.hinze@gmail.com) - Logging in: Connected to server, logging in
15:27 <@root> jabber(paul.t.hinze@gmail.com) - Couldn't log in: Short write() to server
15:27 <@root> jabber(paul.t.hinze@gmail.com) - Logging in: Signing off..

Here is the ldd output on my compiled binary:

$ ldd /usr/local/sbin/bitlbee 
        linux-gate.so.1 =>  (0xb7f5d000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb7f29000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb7e72000)
        libssl.so.0.9.8 => /usr/lib/i686/cmov/libssl.so.0.9.8 (0xb7e2b000)
        libcrypto.so.0.9.8 => /usr/lib/i686/cmov/libcrypto.so.0.9.8 (0xb7ce0000)
        libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7b82000)
        libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7b7e000)
        libpcre.so.3 => /lib/libpcre.so.3 (0xb7b54000)
        /lib/ld-linux.so.2 (0xb7f43000)

I am going to try with gnutls instead and see if that resolves the problem, but I figure this does effectively open the issue back up as it's not gentoo-specific.

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.