#273 closed defect (wontfix)

windows ports leaks threads when connected to yahoo

Reported by: brian.ewins@… Owned by: wilmer
Priority: normal Milestone:
Component: Yahoo Version: 0.92
Keywords: Cc:
IRC client+version: ChatZilla [Firefox] Operating System: Windows
OS version/distro:


Easy to reproduce - connect to yahoo, open the task manager, and start sending messages. Every message you send leaves another thread running. Ouch.

There's something else also leaking threads - possibly when bitlbee reconnects to yahoo and fetches your buddy list - because when bitlbee is left running overnight I regularly come in to find that its not responding to yahoo; investigating that today when it happened again, I found there were nearly 2000 threads (and 19,000+ handles) in the bitlbee process. I havent sent that many IMs.

From a users perspective, the only clues that this has happened is if someone tells you they tried to IM you and you didn't see it. Also, in the windows process 'Logs' tab, you'll see a message about it being unable to create a thread (followed by a bunch of socket errors). Unfortunately the log messages are pretty useless because (a) you can't resize the dialog box to actually read them, (b) they aren't going to a file or in the windows event log as far as I can tell; (c) you can't copy and paste them. In this case, though, the leak is happening long before you see anything in the log and appears to be the primary problem.

I'd love to try out more recent builds to see if this is fixed, but only available windows port is quite old and I can't build it; obviously this isn't a problem that looking at the public server can help with. I couldn't see any tickets related to threads for other platforms though, so I don't know if this has been reported/fixed/whatever in a more recent non-windows build.

Attachments (0)

Change History (4)

comment:1 Changed at 2007-05-02T05:22:09Z by wilmer

Ouch! This is really nasty? Which version is this, the Cygwin or the native port?

comment:2 Changed at 2007-05-02T09:11:47Z by brian.ewins@…

Its the native win32 port, v0.92 from I haven't tried the cygwin port, but I see its 0.92-based too.

comment:3 Changed at 2008-04-19T13:13:10Z by wilmer

Hrmm, I was going to make this bug more generic since I see the Yahoo! module is leaking sockets on Linux systems (not threads, BitlBee doesn't use threads at all but I assume the Win32 port uses threads for event polling), but this seems to be different.

Also, 0.92 is *very* old. Unfortunately we don't have anything really better than that. Jelmer is working on that though.

comment:4 Changed at 2014-09-27T16:56:14Z by dx

Resolution: wontfix
Status: newclosed

Closing this for the same reason as #247:

Revision 1053 removes the old win32 support. Use cygwin instead (recent revisions also improved support for it)

Modify Ticket

as closed The owner will remain wilmer.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.