Modify

#131 closed defect (fixed)

Crash bug after removing unknown handle

Reported by: timing Owned by:
Priority: critical Milestone:
Component: BitlBee Version: devel
Keywords: add -tmp remove disconnect Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro:

Description

This is the output of the bitlbee fork daemon after crashing:

GLib-CRITICAL **: file gstrfuncs.c: line 1195 (g_strcasecmp): assertion `s2 != NULL' failed.

GLib-CRITICAL **: file gstrfuncs.c: line 1195 (g_strcasecmp): assertion `s2 != NULL' failed.
free(): invalid pointer 0x8101508!
Segmentation fault

This is what i did, as you can see i made a lot of typo's:

21:18:00 <@timing> add -tmp 0 someone123
21:18:00 <@root> User `someone123' added to your contact list as `marlotjuh123'
21:18:10 <@root> msn - Error: MSN: Error reported by switchboard server: Invalid handle
21:18:11 <@timing> someone123: yo!
21:18:11 <@root> msn - Error: MSN: Error reported by switchboard server: Invalid handle
21:18:28 <@timing> add -tmp 0 someone123@hotmail.co
21:18:28 <@root> User `someone123@hotmail.co' added to your contact list as `marlotjuh123_'
21:18:29 <@timing> add -tmp 0 someone123@hotmail.com
21:18:29 <@root> User `someone123@hotmail.com' added to your contact list as `marlotjuh123__'
21:18:35 <@timing> remove someone123
21:18:36 <@root> Buddy `someone123' (nick someone123) removed from contact list
21:18:36 <@root> msn - Login error: Error while reading from server
21:18:36 <@root> msn - Signing off..

Everybody quits from msn now. Then I tried to reconnect again:

21:18:36 <@root> msn - Reconnecting in 360 seconds..
21:18:38 <@timing> account on
21:18:38 <@root> Trying to get all accounts connected...
21:18:38 <@root> msn - Logging in: Connecting
21:18:39 <@root> msn - Logging in: Connected to server, waiting for reply
21:18:39 <@root> msn - Logging in: Transferring to other server
21:18:39 <@root> msn - Logging in: Connected to server, waiting for reply
21:18:47 <@timing> remove someone123_
21:18:47 <@root> Buddy `someone123_' not found
21:18:53 <@timing> add -tmp 0 someone123@hotmail.com
21:18:53 <@root> That account is not on-line
21:18:57 <@timing> acocunt on
21:18:57 <@root> Unknown command: acocunt. Please use help commands to get a list of available commands.
21:19:04 <@timing> account on
21:19:04 <@root> Trying to get all accounts connected...
21:19:11 <@timing> help

After recieving the help data, this happends:

21:19:14 <@root> Trying to get all accounts connected...
21:19:29 <@root> msn - Logging in: Authenticated, getting buddy list

30 seconds after the 'Loggin in' The above GLib error appeared.

Too bad, I'm unable to reproduce it, maybe because i need to be transferred to another server, or just because the moon isn't that bright anymore.

Attachments (0)

Change History (2)

comment:1 Changed at 2006-04-04T19:38:20Z by wilmer

Resolution: fixed
Status: newclosed

Sorry, but this is really useless without real steps to reproduce the problem... When you find them, you can reopen the ticket. :-)

comment:2 Changed at 2006-04-04T19:38:41Z by wilmer

Err... Not fixed, but invalid. But never mind. ;-)

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.