Modify

#1150 closed defect (fixed)

otr info display problems

Reported by: freefall Owned by: pesco
Priority: normal Milestone:
Component: OTR Version: 3.2.1
Keywords: Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro:

Description

Using recent bitlbee builds (currently 3.2.1+otr4+20140404+devel+1015-1) in Debian, there seem to be problems with the otr info command.

Regardless of the state of the OTR connection, otr info <nick> always displays connection state: cleartext and displays a non-bold fingerprint (should be bold when OTR is active).

In addition I always see two or more connection context entries for each contact in otr info (whether the contact is online or not). Sometimes one is bold and sometimes not. This may be as expected, but it's somewhat confusing.

The result of all this is that it's hard for a user to tell whether OTR really is active or not, which is a real problem: it should always be very clear when sent/received messages are encrypted and when they're not.

Attachments (1)

otr_info-2015010800.patch (6.6 KB) - added by anonymous at 2015-01-08T02:43:53Z.

Download all attachments as: .zip

Change History (12)

comment:1 in reply to:  description Changed at 2014-07-14T17:36:07Z by dx

Replying to freefall:

Regardless of the state of the OTR connection, otr info <nick> always displays connection state: cleartext and displays a non-bold fingerprint (should be bold when OTR is active).

Works for me, displays 'encrypted' and bold.

In addition I always see two or more connection context entries for each contact in otr info (whether the contact is online or not). Sometimes one is bold and sometimes not. This may be as expected, but it's somewhat confusing.

Sounds vaguely familiar but I can't reproduce it right now.

comment:2 Changed at 2014-12-14T18:59:46Z by anonymous

Same problem on a fresh FreeBSD 10.1-RELEASE-p1 install with bitlbee 3.2.2.

===> The following configuration options are available for bitlbee-3.2.2_3:

DEBUG=off: Build with debugging support DOCS=on: Build and/or install documentation EXAMPLES=on: Build and/or install examples IPV6=on: IPv6 protocol support OTR=on: Off-the-Record Messaging support (Requires GnuTLS)

====> Options available for the multi PROTO: you have to choose at least one of them

JABBER=on: Jabber communications protocol support LIBPURPLE=off: Use libpurple for protocol support MSN=off: Microsoft Messenger support OSCAR=off: OSCAR (ICQ, AIM) support TWITTER=on: Twitter support YAHOO=off: Yahoo! Messenger support

====> SSL protocol support: you have to select exactly one of them

OPENSSL=off: SSL/TLS support via OpenSSL GNUTLS=on: SSL/TLS support via GnuTLS

===> Use 'make config' to modify these settings

comment:3 Changed at 2015-01-02T23:25:37Z by anonymous

Same problem here on FreeBSD 9.3. I believe this issue first appeared after the switch from libotr3 to libotr4.

comment:4 Changed at 2015-01-05T08:59:17Z by anonymous

Same problem here.

  • libotr5 4.0.0-2.2ubuntu1
  • bitlbee 3.2.1+otr4-1

comment:5 Changed at 2015-01-06T02:12:05Z by anonymous

It would appear that the show_otr_context_info() function in otr.c needs a small rewrite (including output format) to handle the multiple contexts that libotr4 uses for v3 instances. Currently, the function checks/displays only the master context for a user, which should work for OTRv2. OTRv3 adds additional contexts for each separate instance. Section 3.2 in the following URL provides a bit more detail:

https://otr.cypherpunks.ca/UPGRADING-libotr-4.1.0.txt

I hope that helps someone make the necessary changes. If not, I'll write a patch myself when I find the time.

comment:6 in reply to:  5 ; Changed at 2015-01-06T12:43:51Z by pesco

Replying to anonymous:

It would appear that the show_otr_context_info() function in otr.c needs a small rewrite (including output format) to handle the multiple contexts that libotr4 uses for v3 instances. Currently, the function checks/displays only the master context for a user, which should work for OTRv2. OTRv3 adds additional contexts for each separate instance.

Precisely. In fact the info display has needed revisiting since almost day one. It looks nice when you have only a handful of contacts but mine just drowns me in fingerprints these days.

I hope that helps someone make the necessary changes. If not, I'll write a patch myself when I find the time.

This would actually be great since it's hard for me to find the time. Plus the info display stuff should be fairly easy to get into.

comment:7 in reply to:  6 ; Changed at 2015-01-08T02:42:45Z by anonymous

Replying to pesco:

This would actually be great since it's hard for me to find the time. Plus the info display stuff should be fairly easy to get into.

Please find otr_info-2015010800.patch uploaded. I think it provides a basic fix for this issue, but I doubt the output is ideal still. I tried to stick to the existing code/output style, but feel free to make changes if anything's not to your liking. In particular, you may like to look at my change to show_fingerprints(), and passing bestctx to show_otr_context_info(), as these may not be the approaches you would use.

This patch is applied to bitlbee-3.2.2.tar.gz, as I don't use bzr to access the latest dev version.

Changed at 2015-01-08T02:43:53Z by anonymous

Attachment: otr_info-2015010800.patch added

comment:8 in reply to:  7 Changed at 2015-01-08T02:59:40Z by anonymous

Replying to pesco:

I forgot to mention that I also removed the "otr offer status" output. It didn't seem to be showing reliable information for either the master context or the instances. Maybe it worked better for v1 or v2 sessions (I didn't test any of those).

comment:9 Changed at 2015-04-10T22:04:27Z by anonymous

otr.c seems to have undergone minor cosmetic changes (whitespaces added/removed) between 3.2.2 and 3.4, which means this patch no longer applies cleanly.

comment:10 Changed at 2015-04-11T15:34:32Z by anonymous

Patch updated. Couldn't upload it here for some reason, so made a gist:

https://gist.github.com/anonymous/a273a9796df258ee5190

comment:11 Changed at 2015-05-15T03:22:03Z by dx

Resolution: fixed
Status: newclosed

Modify Ticket

Action
as closed The owner will remain pesco.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.