Modify

#1137 closed enhancement (duplicate)

Jabber MUC should use real topic of room

Reported by: anonymous Owned by: wilmer
Priority: normal Milestone:
Component: Jabber Version: 3.2.1
Keywords: Cc:
IRC client+version: Client-independent Operating System: Public server
OS version/distro:

Description

Hi,

jabber MUC conferences should use topic of the room instead that message saying "root commands won't work here".. This warning should be sent once as notification when user joins room.

Attachments (1)

0001-Fix-receiving-channel-topic-when-the-from-field-is-u.patch (1.1 KB) - added by dx at 2014-07-24T10:45:49Z.
Fix receiving channel topic when the "from" field is unknown

Download all attachments as: .zip

Change History (4)

comment:1 Changed at 2014-03-02T01:45:38Z by dx

Did a quick search for duplicates, and apparently #302 and #345 talk about this, and are marked as fixed. They are from the 1.x era, though. Not sure what happened there.

comment:2 Changed at 2014-03-02T10:57:49Z by wilmer

This does work (you can even change the topic from BitlBee), the trick is that it only works if the person who set the topic is present in the room at joining time. It shouldn't be too hard to work around this.

Changed at 2014-07-24T10:45:49Z by dx

Fix receiving channel topic when the "from" field is unknown

comment:3 Changed at 2015-10-16T13:58:18Z by dx

Resolution: duplicate
Status: newclosed

That patch was applied in 3.4.1 so this is fixed.

Also this is a duplicate of #406 and that one is older so closing this one as duplicate and the other as fixed.

Modify Ticket

Action
as closed The owner will remain wilmer.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.