Modify

#1040 closed defect (duplicate)

glibc detected invalid free in ssl_disconnect when using NSS

Reported by: pp@… Owned by:
Priority: normal Milestone:
Component: BitlBee Version: Unlisted == unsupported.
Keywords: Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro: Fedora 18

Description

When running 3.2 from Fedora 18 (msn + facebook xmpp with openid connected) I often get a bitlbee crash.

( https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=918816 seems to be downstream bug, 3.0.5 works fine here too). Quickly looking at the code, smells like a ssl_nss.c issue that wouldn't happen with say openssl.

Mar 24 12:10:08 the bitlbee[13905]: * glibc detected * /usr/sbin/bitlbee: free(): invalid pointer: 0x00007fca017ad4ab * Mar 24 12:10:08 the bitlbee[13905]: ======= Backtrace: ========= Mar 24 12:10:08 the bitlbee[13905]: /lib64/libc.so.6(+0x360a27ca8e)[0x7fc9fd0d1a8e] Mar 24 12:10:08 the bitlbee[13905]: /lib64/libglib-2.0.so.0(g_free+0xf)[0x7fc9fecbe79f] Mar 24 12:10:08 the bitlbee[13905]: /usr/sbin/bitlbee(ssl_disconnect+0x1b)[0x7fc9ff5f18fb] Mar 24 12:10:08 the bitlbee[13905]: /usr/sbin/bitlbee(+0x3ff58)[0x7fc9ff601f58] Mar 24 12:10:08 the bitlbee[13905]: /usr/sbin/bitlbee(imc_logout+0xb0)[0x7fc9ff5f5ba0] Mar 24 12:10:08 the bitlbee[13905]: /usr/sbin/bitlbee(sasl_pkt_result+0x9b)[0x7fc9ff60776b] Mar 24 12:10:08 the bitlbee[13905]: /usr/sbin/bitlbee(xt_handle+0xd4)[0x7fc9ff5f23e4] Mar 24 12:10:08 the bitlbee[13905]: /usr/sbin/bitlbee(xt_handle+0x57)[0x7fc9ff5f2367] Mar 24 12:10:08 the bitlbee[13905]: /usr/sbin/bitlbee(+0x3cd95)[0x7fc9ff5fed95] Mar 24 12:10:08 the bitlbee[13905]: /usr/sbin/bitlbee(+0x27a75)[0x7fc9ff5e9a75] Mar 24 12:10:08 the bitlbee[13905]: /lib64/libglib-2.0.so.0(g_main_context_dispatch+0x135)[0x7fc9fecb8a55] Mar 24 12:10:08 the bitlbee[13905]: /lib64/libglib-2.0.so.0(+0x360ca47d88)[0x7fc9fecb8d88] Mar 24 12:10:08 the bitlbee[13905]: /lib64/libglib-2.0.so.0(g_main_loop_run+0x72)[0x7fc9fecb9182] Mar 24 12:10:08 the bitlbee[13905]: /usr/sbin/bitlbee(main+0x24f)[0x7fc9ff5d512f] Mar 24 12:10:08 the bitlbee[13905]: /lib64/libc.so.6(libc_start_main+0xf5)[0x7fc9fd076a05] Mar 24 12:10:08 the bitlbee[13905]: /usr/sbin/bitlbee(+0x13695)[0x7fc9ff5d5695] Mar 24 12:10:08 the bitlbee[13905]: ======= Memory map: ======== Mar 24 12:10:08 the bitlbee[13905]: 7fc9f5ee5000-7fc9f5eea000 r-xp 00000000 08:24 4195038 /usr/lib64/libnss_dns-2.16.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9f5eea000-7fc9f60ea000 ---p 00005000 08:24 4195038 /usr/lib64/libnss_dns-2.16.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9f60ea000-7fc9f60eb000 r--p 00005000 08:24 4195038 /usr/lib64/libnss_dns-2.16.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9f60eb000-7fc9f60ec000 rw-p 00006000 08:24 4195038 /usr/lib64/libnss_dns-2.16.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9f60ec000-7fc9f60f8000 r-xp 00000000 08:24 4195040 /usr/lib64/libnss_files-2.16.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9f60f8000-7fc9f62f7000 ---p 0000c000 08:24 4195040 /usr/lib64/libnss_files-2.16.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9f62f7000-7fc9f62f8000 r--p 0000b000 08:24 4195040 /usr/lib64/libnss_files-2.16.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9f62f8000-7fc9f62f9000 rw-p 0000c000 08:24 4195040 /usr/lib64/libnss_files-2.16.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9f62f9000-7fc9f635f000 r-xp 00000000 08:24 4219745 /usr/lib64/libfreebl3.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9f635f000-7fc9f655f000 ---p 00066000 08:24 4219745 /usr/lib64/libfreebl3.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9f655f000-7fc9f6560000 r--p 00066000 08:24 4219745 /usr/lib64/libfreebl3.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9f6560000-7fc9f6561000 rw-p 00067000 08:24 4219745 /usr/lib64/libfreebl3.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9f6561000-7fc9f6565000 rw-p 00000000 00:00 0 Mar 24 12:10:08 the bitlbee[13905]: 7fc9f6565000-7fc9f660b000 r-xp 00000000 08:24 4200919 /usr/lib64/libsqlite3.so.0.8.6 Mar 24 12:10:08 the bitlbee[13905]: 7fc9f660b000-7fc9f680a000 ---p 000a6000 08:24 4200919 /usr/lib64/libsqlite3.so.0.8.6 Mar 24 12:10:08 the bitlbee[13905]: 7fc9f680a000-7fc9f680c000 r--p 000a5000 08:24 4200919 /usr/lib64/libsqlite3.so.0.8.6 Mar 24 12:10:08 the bitlbee[13905]: 7fc9f680c000-7fc9f680e000 rw-p 000a7000 08:24 4200919 /usr/lib64/libsqlite3.so.0.8.6 Mar 24 12:10:08 the bitlbee[13905]: 7fc9f680e000-7fc9f680f000 rw-p 00000000 00:00 0 Mar 24 12:10:08 the bitlbee[13905]: 7fc9f680f000-7fc9f684d000 r-xp 00000000 08:24 4211302 /usr/lib64/libsoftokn3.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9f684d000-7fc9f6a4d000 ---p 0003e000 08:24 4211302 /usr/lib64/libsoftokn3.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9f6a4d000-7fc9f6a4e000 r--p 0003e000 08:24 4211302 /usr/lib64/libsoftokn3.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9f6a4e000-7fc9f6a4f000 rw-p 0003f000 08:24 4211302 /usr/lib64/libsoftokn3.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9f6a4f000-7fc9fce3f000 r--p 00000000 08:24 4213482 /usr/lib/locale/locale-archive Mar 24 12:10:08 the bitlbee[13905]: 7fc9fce3f000-7fc9fce54000 r-xp 00000000 08:24 4211801 /usr/lib64/libz.so.1.2.7 Mar 24 12:10:08 the bitlbee[13905]: 7fc9fce54000-7fc9fd053000 ---p 00015000 08:24 4211801 /usr/lib64/libz.so.1.2.7 Mar 24 12:10:08 the bitlbee[13905]: 7fc9fd053000-7fc9fd054000 r--p 00014000 08:24 4211801 /usr/lib64/libz.so.1.2.7 Mar 24 12:10:08 the bitlbee[13905]: 7fc9fd054000-7fc9fd055000 rw-p 00015000 08:24 4211801 /usr/lib64/libz.so.1.2.7 Mar 24 12:10:08 the bitlbee[13905]: 7fc9fd055000-7fc9fd202000 r-xp 00000000 08:24 4196137 /usr/lib64/libc-2.16.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9fd202000-7fc9fd402000 ---p 001ad000 08:24 4196137 /usr/lib64/libc-2.16.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9fd402000-7fc9fd406000 r--p 001ad000 08:24 4196137 /usr/lib64/libc-2.16.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9fd406000-7fc9fd408000 rw-p 001b1000 08:24 4196137 /usr/lib64/libc-2.16.so Mar 24 12:10:08 the bitlbee[13905]: 7fc9fd408000-7fc9fd40d000 rw-p 00000000 00:00 0 Mar 24 12:10:08 the bitlbee[13905]: 7fc9fd40d000-7fc9fd422000 r-xp 00000000 08:24 4219690 /usr/lib64/libgcc_s-4.7.2-20121109.so.1 Mar 24 12:10:08 the bitlbee[13905]: 7fc9fd422000-7fc9fd621000 ---p 00015000 08:24 4219690 /usr/lib64/libgcc_s-4.7.2-20121109.so.1 Mar 24 12:10:08 the bitlbee[13905]: 7fc9fd621000-7fc9fd622000 r--p 00014000 08:24 4219690 /usr/lib64/libgcc_s-4.7.2-20121109.so.1 Mar 24 12:10:08 the bitlbee[13905]: 7fc9fd622000-7fc9fd623000 rw-p 00015000 08:24 4219690 /usr/lib64/libgcc_s-4.7.2-20121109.so.1 Mar 24 12:10:08 the bitlbee[13905]: 7fc9fd623000-7fc9fd639000 r-xp 00000000 08:24 4219718 /usr/lib64/libresolv-2.16.so Mar 24 12:10:08 the systemd[1]: bitlbee.service: main process exited, code=killed, status=6/ABRT Mar 24 12:10:08 the systemd[1]: Unit bitlbee.service entered failed state

Attachments (0)

Change History (2)

comment:1 Changed at 2013-03-25T13:17:22Z by pp@…

Duplicate of 1038 it seems. Testing patch from https://bugzilla.redhat.com/attachment.cgi?id=713833&action=diff&context=patch&collapsed=&headers=1&format=raw as a fix but this can be closed.

comment:2 Changed at 2013-04-01T22:36:25Z by wilmer

Resolution: duplicate
Status: newclosed

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.