Changeset ac3b8ff for debian/rules
- Timestamp:
- 2018-03-19T17:02:01Z (7 years ago)
- Branches:
- master
- Children:
- 1c7b646
- Parents:
- 1de945b
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
debian/rules
r1de945b rac3b8ff 9 9 10 10 # Include the bitlbee-libpurple variant and OTR plugin by default. 11 # Don't build skype by default since it depends on deleted/non-free12 # packages. Need to at least get python-skype back into Debian.13 11 BITLBEE_LIBPURPLE ?= 1 14 12 BITLBEE_OTR ?= plugin 15 BITLBEE_SKYPE ?= 016 13 BITLBEE_CONFIGURE_FLAGS ?= 17 14 DEBUG ?= 0 … … 28 25 ifneq ($(BITLBEE_OTR),plugin) 29 26 DH_OPTIONS += -Nbitlbee-plugin-otr 30 endif31 32 ifneq ($(BITLBEE_SKYPE),plugin)33 DH_OPTIONS += -Nbitlbee-plugin-skype -Nskyped34 27 endif 35 28 … … 52 45 53 46 mkdir -p debian/build-native 54 ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --skype=$(BITLBEE_SKYPE)$(BITLBEE_CONFIGURE_FLAGS)47 ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) $(BITLBEE_CONFIGURE_FLAGS) 55 48 $(MAKE) -C debian/build-native 56 49 … … 86 79 $(MAKE) -C debian/build-native install-dev DESTDIR=`pwd`/debian/bitlbee-dev 87 80 $(MAKE) -C debian/build-native install-plugin-otr DESTDIR=`pwd`/debian/bitlbee-plugin-otr 88 $(MAKE) -C debian/build-native install-plugin-skype DESTDIR=`pwd`/debian/skyped89 81 90 82 ifeq ($(HAS_DH_SYSTEMD),1) 91 83 $(MAKE) -C debian/build-native install-systemd DESTDIR=`pwd`/debian/bitlbee-common 92 endif93 94 ifneq ($(BITLBEE_SKYPE),0)95 mkdir -p debian/bitlbee-plugin-skype/usr96 mv debian/skyped/usr/lib debian/bitlbee-plugin-skype/usr97 98 mkdir -p debian/skyped/usr/share/man/man199 mv debian/bitlbee-common/usr/share/man/man1/skyped* debian/skyped/usr/share/man/man1100 84 endif 101 85
Note: See TracChangeset
for help on using the changeset viewer.