Changeset ac3b8ff for debian/rules


Ignore:
Timestamp:
2018-03-19T17:02:01Z (6 years ago)
Author:
dequis <dx@…>
Branches:
master
Children:
1c7b646
Parents:
1de945b
Message:

debian: remove skype plugin stuff

File:
1 edited

Legend:

Unmodified
Added
Removed
  • debian/rules

    r1de945b rac3b8ff  
    99
    1010# Include the bitlbee-libpurple variant and OTR plugin by default.
    11 # Don't build skype by default since it depends on deleted/non-free
    12 # packages. Need to at least get python-skype back into Debian.
    1311BITLBEE_LIBPURPLE ?= 1
    1412BITLBEE_OTR ?= plugin
    15 BITLBEE_SKYPE ?= 0
    1613BITLBEE_CONFIGURE_FLAGS ?=
    1714DEBUG ?= 0
     
    2825ifneq ($(BITLBEE_OTR),plugin)
    2926DH_OPTIONS += -Nbitlbee-plugin-otr
    30 endif
    31 
    32 ifneq ($(BITLBEE_SKYPE),plugin)
    33 DH_OPTIONS += -Nbitlbee-plugin-skype -Nskyped
    3427endif
    3528
     
    5245
    5346        mkdir -p debian/build-native
    54         ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --skype=$(BITLBEE_SKYPE) $(BITLBEE_CONFIGURE_FLAGS)
     47        ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) $(BITLBEE_CONFIGURE_FLAGS)
    5548        $(MAKE) -C debian/build-native
    5649
     
    8679        $(MAKE) -C debian/build-native install-dev DESTDIR=`pwd`/debian/bitlbee-dev
    8780        $(MAKE) -C debian/build-native install-plugin-otr DESTDIR=`pwd`/debian/bitlbee-plugin-otr
    88         $(MAKE) -C debian/build-native install-plugin-skype DESTDIR=`pwd`/debian/skyped
    8981
    9082ifeq ($(HAS_DH_SYSTEMD),1)
    9183        $(MAKE) -C debian/build-native install-systemd DESTDIR=`pwd`/debian/bitlbee-common
    92 endif
    93 
    94 ifneq ($(BITLBEE_SKYPE),0)
    95         mkdir -p debian/bitlbee-plugin-skype/usr
    96         mv debian/skyped/usr/lib debian/bitlbee-plugin-skype/usr
    97 
    98         mkdir -p debian/skyped/usr/share/man/man1
    99         mv debian/bitlbee-common/usr/share/man/man1/skyped* debian/skyped/usr/share/man/man1
    10084endif
    10185
Note: See TracChangeset for help on using the changeset viewer.