Changeset 27b407f for debian/rules
- Timestamp:
- 2010-10-09T18:28:33Z (14 years ago)
- Branches:
- master
- Children:
- 6197702
- Parents:
- 508588a
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
debian/rules
r508588a r27b407f 8 8 # 9 9 10 # Include the bitlbee-libpurple variant by default10 # Include the bitlbee-libpurple variant and OTR plugin by default 11 11 BITLBEE_LIBPURPLE ?= 1 12 BITLBEE_OTR ?= plugin 12 13 BITLBEE_CONFIGURE_FLAGS ?= 13 14 DEBUG ?= 0 … … 22 23 endif 23 24 25 ifneq ($(BITLBEE_OTR),plugin) 26 DH_OPTIONS += -Nbitlbee-plugin-otr 27 endif 28 24 29 build: build-stamp 25 30 build-stamp: … … 27 32 28 33 mkdir -p debian/build-native 29 ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent $(BITLBEE_CONFIGURE_FLAGS)34 ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) $(BITLBEE_CONFIGURE_FLAGS) 30 35 $(MAKE) -C debian/build-native 31 36 … … 56 61 dh_installdirs 57 62 58 $(MAKE) -C debian/build-native install DESTDIR=`pwd`/debian/bitlbee59 $(MAKE) -C debian/build-native install-etc DESTDIR=`pwd`/debian/bitlbee-common63 $(MAKE) -C debian/build-native install-bin DESTDIR=`pwd`/debian/bitlbee 64 $(MAKE) -C debian/build-native install-etc install-doc DESTDIR=`pwd`/debian/bitlbee-common 60 65 $(MAKE) -C debian/build-native install-dev DESTDIR=`pwd`/debian/bitlbee-dev 61 patch debian/bitlbee-common/etc/bitlbee/bitlbee.conf debian/patches/bitlbee.conf.diff66 $(MAKE) -C debian/build-native install-plugins DESTDIR=`pwd`/debian/bitlbee-plugin-otr 62 67 63 68 ifeq ($(BITLBEE_LIBPURPLE),1) 64 $(MAKE) -C debian/build-libpurple install DESTDIR=`pwd`/debian/bitlbee-libpurple69 $(MAKE) -C debian/build-libpurple install-bin DESTDIR=`pwd`/debian/bitlbee-libpurple 65 70 ln -sf debian/bitlbee.prerm debian/bitlbee-libpurple.prerm 66 71 endif 67 72 68 mkdir -p debian/bitlbee-common/usr 69 mv debian/bitlbee/usr/share debian/bitlbee-common/usr 70 rm -rf debian/bitlbee-libpurple/usr/share 73 patch debian/bitlbee-common/etc/bitlbee/bitlbee.conf debian/patches/bitlbee.conf.diff 74 chmod 640 debian/bitlbee-common/etc/bitlbee/bitlbee.conf 71 75 72 76 binary-common: … … 79 83 # TODO: Restore --link-doc up here and remove the hack below once 80 84 # Hardy and Lenny are deprecated. 81 for p in bitlbee bitlbee-libpurple bitlbee-dev ; do rm -r debian/$$p/usr/share/doc/$$p && ln -s bitlbee-common debian/$$p/usr/share/doc/$$p; done85 for p in bitlbee bitlbee-libpurple bitlbee-dev bitlbee-plugin-otr; do rm -r debian/$$p/usr/share/doc/$$p && ln -s bitlbee-common debian/$$p/usr/share/doc/$$p || true; done 82 86 dh_installdebconf 83 87 dh_installinit --init-script=bitlbee
Note: See TracChangeset
for help on using the changeset viewer.