Changeset 164352e for debian/rules
- Timestamp:
- 2011-12-24T18:02:39Z (13 years ago)
- Branches:
- master
- Children:
- 34ded90
- Parents:
- e306fbf (diff), 96f954d (diff)
Note: this is a merge changeset, the changes displayed below correspond to the merge itself.
Use the(diff)
links above to see all the changes relative to each parent. - File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
debian/rules
re306fbf r164352e 8 8 # 9 9 10 # Include the bitlbee-libpurple variant and OTR plugin by default 10 # Include the bitlbee-libpurple variant and OTR plugin by default. 11 # Don't build skype by default since it depends on deleted/non-free 12 # packages. Need to at least get python-skype back into Debian. 11 13 BITLBEE_LIBPURPLE ?= 1 12 14 BITLBEE_OTR ?= plugin 13 BITLBEE_SKYPE ?= plugin15 BITLBEE_SKYPE ?= 0 14 16 BITLBEE_CONFIGURE_FLAGS ?= 15 17 DEBUG ?= 0 … … 17 19 ifndef BITLBEE_VERSION 18 20 # Want to use the full package version number instead of just the release. 19 BITLBEE_CONFIGURE_VERSION ?= BITLBEE_VERSION=\"$(shell dpkg-parsechangelog | grep ^Version: | awk '{print $$2}')\"21 BITLBEE_CONFIGURE_VERSION ?= BITLBEE_VERSION=\"$(shell dpkg-parsechangelog | awk '/^Version:/ {print $$2}')\" 20 22 endif 21 23 … … 72 74 $(MAKE) -C debian/build-native install-plugin-skype DESTDIR=`pwd`/debian/skyped 73 75 76 ifneq ($(BITLBEE_SKYPE),0) 74 77 mkdir -p debian/bitlbee-plugin-skype/usr 75 78 mv debian/skyped/usr/lib debian/bitlbee-plugin-skype/usr … … 77 80 mkdir -p debian/skyped/usr/share/man/man1 78 81 mv debian/bitlbee-common/usr/share/man/man1/skyped* debian/skyped/usr/share/man/man1 82 endif 79 83 80 84 ifeq ($(BITLBEE_LIBPURPLE),1) … … 106 110 dh_installdeb 107 111 dh_shlibdeps 108 ifdef BITLBEE_VERSION 109 dh_gencontrol -- -v$(BITLBEE_VERSION) -Vbee:Version=$(BITLBEE_VERSION) 110 else 111 dh_gencontrol -- -Vbee:Version=$(shell dpkg-parsechangelog | grep ^Version: | awk '{print $$2}' | sed -e 's/+b[0-9]\+$$//') 112 endif 112 dh_gencontrol 113 113 dh_md5sums 114 114 dh_builddeb
Note: See TracChangeset
for help on using the changeset viewer.