source: debian/rules @ eaffd0d

3.5-1.1
Last change on this file since eaffd0d was b5fb903, checked in by dequis <dx@…>, at 2017-01-27T00:46:49Z

debian: Merge changes from 3.4.2-1.1 NMU into 3.5-1

Because apparently not having build-arch is now a build failure, even
though lintian only considered it a warning and a "recommended" target

  • Property mode set to 100755
File size: 4.4 KB
RevLine 
[19a8088]1#!/usr/bin/make -f
[095a5f0]2#
3# Finally switching to debhelper.
4#
5# Not using debhelper was an exercise suggested to me by my AM (Gergely
6# Nagy). It was educating at the time but I finally decided that the
7# exercise is over now.
8#
[19a8088]9
[6c0fe9b]10# Include the bitlbee-libpurple variant and OTR plugin by default.
11# Don't build skype by default since it depends on deleted/non-free
12# packages. Need to at least get python-skype back into Debian.
[d20ea9f]13BITLBEE_LIBPURPLE ?= 1
[27b407f]14BITLBEE_OTR ?= plugin
[6c0fe9b]15BITLBEE_SKYPE ?= 0
[b5b40ff]16BITLBEE_CONFIGURE_FLAGS ?=
[19a8088]17DEBUG ?= 0
18
[4c03881]19ifndef BITLBEE_VERSION
[19a8088]20# Want to use the full package version number instead of just the release.
[0edb57f]21BITLBEE_CONFIGURE_VERSION ?= BITLBEE_VERSION="$(shell dpkg-parsechangelog | awk '/^Version:/ {print $$2}')"
[379c08a]22endif
[19a8088]23
[763a3ab]24ifneq ($(BITLBEE_LIBPURPLE),1)
25DH_OPTIONS += -Nbitlbee-libpurple
26endif
27
[27b407f]28ifneq ($(BITLBEE_OTR),plugin)
29DH_OPTIONS += -Nbitlbee-plugin-otr
30endif
31
[57da960]32ifneq ($(BITLBEE_SKYPE),plugin)
33DH_OPTIONS += -Nbitlbee-plugin-skype -Nskyped
34endif
35
[e01ff50]36CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
37CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
38LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
39
40CONFIGURE_OVERRIDES:=CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
41
[135271c]42HAS_DH_SYSTEMD:=$(shell dpkg-query -W -f='$${Status}' dh-systemd 2>/dev/null | grep -c "ok installed")
[b5fb903]43# https://bugs.debian.org/821967
44build-indep: binary-indep
45build-arch: binary-arch
[135271c]46
[095a5f0]47build: build-stamp
48build-stamp:
49        dh_testdir
[19a8088]50
[4772500]51        mkdir -p debian/build-native
[e01ff50]52        ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --skype=$(BITLBEE_SKYPE) $(BITLBEE_CONFIGURE_FLAGS)
[095a5f0]53        $(MAKE) -C debian/build-native
[19a8088]54
[d20ea9f]55ifeq ($(BITLBEE_LIBPURPLE),1)
[4772500]56        mkdir -p debian/build-libpurple
[e01ff50]57        ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --purple=1 $(BITLBEE_CONFIGURE_FLAGS)
[095a5f0]58        $(MAKE) -C debian/build-libpurple
[d20ea9f]59endif
[19a8088]60
[bc49ec2]61        $(MAKE) -C doc
[0d8add8a]62        $(MAKE) -C doc/user-guide
[bc49ec2]63
[095a5f0]64        touch build-stamp
[46d4230]65
[095a5f0]66clean:
67        dh_testdir
68        dh_testroot
69        rm -f build-stamp
[46d4230]70
[5b94e9e]71        rm -rf build-arch-stamp debian/build-* debian/bitlbee-libpurple.prerm
[095a5f0]72        $(MAKE) distclean
[46d4230]73
[095a5f0]74        dh_clean
75
76install: build
77        dh_testdir
78        dh_testroot
[e9a3e8c]79        dh_prep
[095a5f0]80        dh_installdirs
81
[27b407f]82        $(MAKE) -C debian/build-native install-bin DESTDIR=`pwd`/debian/bitlbee
83        $(MAKE) -C debian/build-native install-etc install-doc DESTDIR=`pwd`/debian/bitlbee-common
[095a5f0]84        $(MAKE) -C debian/build-native install-dev DESTDIR=`pwd`/debian/bitlbee-dev
[57da960]85        $(MAKE) -C debian/build-native install-plugin-otr DESTDIR=`pwd`/debian/bitlbee-plugin-otr
86        $(MAKE) -C debian/build-native install-plugin-skype DESTDIR=`pwd`/debian/skyped
87
[135271c]88ifeq ($(HAS_DH_SYSTEMD),1)
89        $(MAKE) -C debian/build-native install-systemd DESTDIR=`pwd`/debian/bitlbee-common
90endif
91
[6c0fe9b]92ifneq ($(BITLBEE_SKYPE),0)
[57da960]93        mkdir -p debian/bitlbee-plugin-skype/usr
94        mv debian/skyped/usr/lib debian/bitlbee-plugin-skype/usr
[d20ea9f]95
[e46db53]96        mkdir -p debian/skyped/usr/share/man/man1
97        mv debian/bitlbee-common/usr/share/man/man1/skyped* debian/skyped/usr/share/man/man1
[6c0fe9b]98endif
[e46db53]99
[d20ea9f]100ifeq ($(BITLBEE_LIBPURPLE),1)
[27b407f]101        $(MAKE) -C debian/build-libpurple install-bin DESTDIR=`pwd`/debian/bitlbee-libpurple
[5b94e9e]102        ln -sf debian/bitlbee.prerm debian/bitlbee-libpurple.prerm
[d20ea9f]103endif
[095a5f0]104
[27b407f]105        patch debian/bitlbee-common/etc/bitlbee/bitlbee.conf debian/patches/bitlbee.conf.diff
106        chmod 640 debian/bitlbee-common/etc/bitlbee/bitlbee.conf
[095a5f0]107
108binary-common:
109        dh_testdir
110        dh_testroot
111
[4772500]112        dh_installchangelogs doc/CHANGES
[095a5f0]113        dh_installexamples
[560d0a0]114        dh_installdocs #--link-doc=bitlbee-common
115        # TODO: Restore --link-doc up here and remove the hack below once
116        # Hardy and Lenny are deprecated.
[27b407f]117        for p in bitlbee bitlbee-libpurple bitlbee-dev bitlbee-plugin-otr; do rm -r debian/$$p/usr/share/doc/$$p && ln -s bitlbee-common debian/$$p/usr/share/doc/$$p || true; done
[095a5f0]118        dh_installdebconf
[135271c]119ifeq ($(HAS_DH_SYSTEMD),1)
120        dh_systemd_enable
[5b94e9e]121        dh_installinit --init-script=bitlbee
[135271c]122        dh_systemd_start
123else
124        dh_installinit --init-script=bitlbee
125endif
[095a5f0]126        dh_installman
[6c2b430]127        dh_lintian
[095a5f0]128        dh_strip
129        dh_link
130        dh_compress
131        dh_fixperms
132        dh_installdeb
133        dh_shlibdeps
[256164c]134        dh_gencontrol
[095a5f0]135        dh_md5sums
136        dh_builddeb
[46d4230]137
[095a5f0]138binary-indep: build install
[763a3ab]139        DH_OPTIONS=-i $(MAKE) -f debian/rules binary-common
[46d4230]140
[095a5f0]141binary-arch: build install
[763a3ab]142        DH_OPTIONS=-a $(MAKE) -f debian/rules binary-common
[19a8088]143
[095a5f0]144binary-%: build install
[763a3ab]145        DH_OPTIONS=-p$* $(MAKE) -f debian/rules binary-common
[19a8088]146
[095a5f0]147binary: binary-indep binary-arch
148.PHONY: build clean binary-indep binary-arch binary-common binary install
Note: See TracBrowser for help on using the repository browser.