source: debian/rules @ d567b58

Last change on this file since d567b58 was e01ff50, checked in by Jelmer Vernooij <jelmer@…>, at 2014-09-27T17:42:49Z

Avoid 'dpkg-buildflags --export=configure, since it doesn't exist in squeeze.

  • Property mode set to 100755
File size: 4.0 KB
RevLine 
[19a8088]1#!/usr/bin/make -f
[095a5f0]2#
3# Finally switching to debhelper.
4#
5# Not using debhelper was an exercise suggested to me by my AM (Gergely
6# Nagy). It was educating at the time but I finally decided that the
7# exercise is over now.
8#
[19a8088]9
[6c0fe9b]10# Include the bitlbee-libpurple variant and OTR plugin by default.
11# Don't build skype by default since it depends on deleted/non-free
12# packages. Need to at least get python-skype back into Debian.
[d20ea9f]13BITLBEE_LIBPURPLE ?= 1
[27b407f]14BITLBEE_OTR ?= plugin
[6c0fe9b]15BITLBEE_SKYPE ?= 0
[b5b40ff]16BITLBEE_CONFIGURE_FLAGS ?=
[19a8088]17DEBUG ?= 0
18
[4c03881]19ifndef BITLBEE_VERSION
[19a8088]20# Want to use the full package version number instead of just the release.
[0edb57f]21BITLBEE_CONFIGURE_VERSION ?= BITLBEE_VERSION="$(shell dpkg-parsechangelog | awk '/^Version:/ {print $$2}')"
[379c08a]22endif
[19a8088]23
[763a3ab]24ifneq ($(BITLBEE_LIBPURPLE),1)
25DH_OPTIONS += -Nbitlbee-libpurple
26endif
27
[27b407f]28ifneq ($(BITLBEE_OTR),plugin)
29DH_OPTIONS += -Nbitlbee-plugin-otr
30endif
31
[57da960]32ifneq ($(BITLBEE_SKYPE),plugin)
33DH_OPTIONS += -Nbitlbee-plugin-skype -Nskyped
34endif
35
[e01ff50]36CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
37CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
38LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
39
40CONFIGURE_OVERRIDES:=CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
41
[095a5f0]42build: build-stamp
43build-stamp:
44        dh_testdir
[19a8088]45
[4772500]46        mkdir -p debian/build-native
[e01ff50]47        ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --skype=$(BITLBEE_SKYPE) $(BITLBEE_CONFIGURE_FLAGS)
[095a5f0]48        $(MAKE) -C debian/build-native
[19a8088]49
[d20ea9f]50ifeq ($(BITLBEE_LIBPURPLE),1)
[4772500]51        mkdir -p debian/build-libpurple
[e01ff50]52        ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --purple=1 $(BITLBEE_CONFIGURE_FLAGS)
[095a5f0]53        $(MAKE) -C debian/build-libpurple
[d20ea9f]54endif
[19a8088]55
[bc49ec2]56        $(MAKE) -C doc
[0d8add8a]57        $(MAKE) -C doc/user-guide
[bc49ec2]58
[095a5f0]59        touch build-stamp
[46d4230]60
[095a5f0]61clean:
62        dh_testdir
63        dh_testroot
64        rm -f build-stamp
[46d4230]65
[5b94e9e]66        rm -rf build-arch-stamp debian/build-* debian/bitlbee-libpurple.prerm
[095a5f0]67        $(MAKE) distclean
[46d4230]68
[095a5f0]69        dh_clean
70
71install: build
72        dh_testdir
73        dh_testroot
[560d0a0]74        dh_clean -k
[095a5f0]75        dh_installdirs
76
[27b407f]77        $(MAKE) -C debian/build-native install-bin DESTDIR=`pwd`/debian/bitlbee
78        $(MAKE) -C debian/build-native install-etc install-doc DESTDIR=`pwd`/debian/bitlbee-common
[095a5f0]79        $(MAKE) -C debian/build-native install-dev DESTDIR=`pwd`/debian/bitlbee-dev
[57da960]80        $(MAKE) -C debian/build-native install-plugin-otr DESTDIR=`pwd`/debian/bitlbee-plugin-otr
81        $(MAKE) -C debian/build-native install-plugin-skype DESTDIR=`pwd`/debian/skyped
82
[6c0fe9b]83ifneq ($(BITLBEE_SKYPE),0)
[57da960]84        mkdir -p debian/bitlbee-plugin-skype/usr
85        mv debian/skyped/usr/lib debian/bitlbee-plugin-skype/usr
[d20ea9f]86
[e46db53]87        mkdir -p debian/skyped/usr/share/man/man1
88        mv debian/bitlbee-common/usr/share/man/man1/skyped* debian/skyped/usr/share/man/man1
[6c0fe9b]89endif
[e46db53]90
[d20ea9f]91ifeq ($(BITLBEE_LIBPURPLE),1)
[27b407f]92        $(MAKE) -C debian/build-libpurple install-bin DESTDIR=`pwd`/debian/bitlbee-libpurple
[5b94e9e]93        ln -sf debian/bitlbee.prerm debian/bitlbee-libpurple.prerm
[d20ea9f]94endif
[095a5f0]95
[27b407f]96        patch debian/bitlbee-common/etc/bitlbee/bitlbee.conf debian/patches/bitlbee.conf.diff
97        chmod 640 debian/bitlbee-common/etc/bitlbee/bitlbee.conf
[095a5f0]98
99binary-common:
100        dh_testdir
101        dh_testroot
102
[4772500]103        dh_installchangelogs doc/CHANGES
[095a5f0]104        dh_installexamples
[560d0a0]105        dh_installdocs #--link-doc=bitlbee-common
106        # TODO: Restore --link-doc up here and remove the hack below once
107        # Hardy and Lenny are deprecated.
[27b407f]108        for p in bitlbee bitlbee-libpurple bitlbee-dev bitlbee-plugin-otr; do rm -r debian/$$p/usr/share/doc/$$p && ln -s bitlbee-common debian/$$p/usr/share/doc/$$p || true; done
[095a5f0]109        dh_installdebconf
[5b94e9e]110        dh_installinit --init-script=bitlbee
[095a5f0]111        dh_installman
[6c2b430]112        dh_lintian
[095a5f0]113        dh_strip
114        dh_link
115        dh_compress
116        dh_fixperms
117        dh_installdeb
118        dh_shlibdeps
[256164c]119        dh_gencontrol
[095a5f0]120        dh_md5sums
121        dh_builddeb
[46d4230]122
[095a5f0]123binary-indep: build install
[763a3ab]124        DH_OPTIONS=-i $(MAKE) -f debian/rules binary-common
[46d4230]125
[095a5f0]126binary-arch: build install
[763a3ab]127        DH_OPTIONS=-a $(MAKE) -f debian/rules binary-common
[19a8088]128
[095a5f0]129binary-%: build install
[763a3ab]130        DH_OPTIONS=-p$* $(MAKE) -f debian/rules binary-common
[19a8088]131
[095a5f0]132binary: binary-indep binary-arch
133.PHONY: build clean binary-indep binary-arch binary-common binary install
Note: See TracBrowser for help on using the repository browser.