Modify

#964 closed defect (notabug)

impossible dependencies

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: BitlBee Version: devel
Keywords: Cc:
IRC client+version: Client-independent Operating System: Linux
OS version/distro:

Description

What is this supposed to mean:

The following packages have unmet dependencies:

bitlbee: Depends: libgnutls26 (>= 2.12.17-0) but 2.12.14-5ubuntu3 is installed.

In Ubuntu there's no version of libgnutls26 >=2.12.17. Even in the brand new Quantal version the version number is only 2.12.14.

Attachments (0)

Change History (8)

comment:1 Changed at 2012-05-24T08:03:53Z by wilmer

What exact package are you trying to install on what distro?

comment:2 Changed at 2012-05-25T00:44:45Z by anonymous

It's all in the original post. I'm trying to install bitlbee (what else?). The newest version. I want to install it on Ubuntu Precise, also the most current version. I point out that even in Ubuntu Quantal the not yet released version which is worked upon the requirement asked for by bitlbee is met. A version of libgnutls26 better than 2.12.17 just don't exist.

Trying it with the aptitude package manager suggests to remove the bitlbee package in order to solve the problem. That's not what I want.

What it comes down to is that due to this ridiculous dependency requirement no one can install the newest bitlbee version. At least on Ubuntu that is. I can't draw conclusions on other systems.

comment:3 Changed at 2012-05-25T00:48:02Z by anonymous

Correction, it should read:

I point out that even in Ubuntu Quantal the not yet released version which is worked upon the requirement asked for by bitlbee is NOT met.

comment:4 Changed at 2012-05-25T06:16:55Z by wilmer

And that's the Ubuntu package, or one of the packages from code.bitlbee.org/debian/ ?

comment:5 Changed at 2012-05-26T01:52:01Z by anonymous

In my sources.list I have:

http://code.bitlbee.org/debian/devel/testing/i386/

So that's the original version from the website. Currently I've a working version 900 but from time to time it suffers from problems as described in bugreport 963, so I assumed I could try the most current version being 908 at the moment.

comment:6 Changed at 2012-05-26T08:32:35Z by wilmer

Resolution: notabug
Status: newclosed

But if you would actually read what it says there instead of blindly copy-pasting the first thing that looks familiar (I'll admit that I sometimes do the same though ;-)) you'd know what you're doing wrong here.

comment:7 Changed at 2012-05-27T00:43:45Z by anonymous

Meaning what?! I've asked your FIRST!

The complete output is:

The following packages will be REMOVED:

libevent-1.4-2{u}

The following packages will be upgraded:

bitlbee{b} bitlbee-common

2 packages upgraded, 0 newly installed, 1 to remove and 1024 not upgraded. Need to get 302 kB/438 kB of archives. After unpacking 1477 kB will be freed. The following packages have unmet dependencies:

bitlbee: Depends: libgnutls26 (>= 2.12.17-0) but 2.12.14-5ubuntu3 is installed.

The following actions will resolve these dependencies:

Remove the following packages:

1) bitlbee

Accept this solution? [Y/n/q/?]

So actually Ubuntu suggest to remove bitlbee altogether. Yes, that's a good a way to promote your software...

comment:8 Changed at 2012-05-27T08:14:48Z by wilmer

JUST READ WHAT THAT PAGE SAYS. You are using a repository for DEBIAN TESTING on UBUNTU PRECISE. Of course that doesn't work. And stop posting on this bug tracker.

I don't care whether people like you use my software or not. BitlBee is a hobby project, it's not like you're paying me.

Version 1, edited at 2012-05-27T08:20:14Z by wilmer (previous) (next) (diff)

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.