Modify

#87 closed enhancement (fixed)

Session take-over

Reported by: siberion@… Owned by:
Priority: wishlist Milestone:
Component: BitlBee Version:
Keywords: Cc:
IRC client+version: Client-independent Operating System: Public server
OS version/distro:

Description

Hi,

I was wondering if it would be possible to allow users to take over a running session from a different computer? That is, suspending a running IRC client/bitlbee connection (while still maintaining the IRC link) and rerouting all IRC traffic to a new IRC client without ever disconnecting/reconnecting bitlbee from the IM servers. Once the second client logs off again, the first session would be resumed (seamlessly again), or else the second client will fully own the session if the first one disconnects from bitlbee.

It's not a necessary feature, but it would be quite convenient. I'd look into writing a patch, but unfortunately I don't have the time for that these days.

Attachments (0)

Change History (3)

comment:1 Changed at 2006-01-19T17:11:03Z by wilmer

I think it wouldn't be very easy to implement. Maybe it's better to use a regular IRC bouncer for this, that way you can already do it today. :-) CtrlProxy is an option, since it can integrate pretty well with BitlBee. (But the thing leaks quite a lot of memory right now...)

But thanks, I'll put it on the "things to do before implementing file transfers" list. >;-)

comment:2 Changed at 2006-01-23T20:55:08Z by wilmer

Marked #92 as a dupe of this bug.

comment:3 Changed at 2012-03-25T23:23:50Z by wilmer

Resolution: fixed
Status: newclosed

Oh, hah, 3.0 did this.

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.