#368 closed defect (fixed)

Bitlbee hangs on buddy list request when compiled with OpenSSL

Reported by: anonymous Owned by:
Priority: normal Milestone: 1.2.1
Component: Jabber Version: devel
Keywords: jabber buddy list hang openssl Cc:
IRC client+version: Client-independent Operating System: MacOS
OS version/distro: Mac OS 10.5


Using nightly build 337 of bitlbee, when compiled with openssl and connecting to the xmpp server, bitlbee hangs after requesting the buddy list from the server. And xmlconsole trace indicates that no buddy list is being received. However, when compiled with gnutls, this same server and setup receives the buddy list perfectly fine. Hardware is Macbook Pro 17" Core Duo running Mac OS 10.5. Bitlbee is running as nobody from a launchd script.

Attachments (0)

Change History (5)

comment:1 Changed at 2008-03-15T23:41:42Z by wilmer

Bah, can't reproduce, I guess it's because I'm "still" on 10.4. There are similar problems on Gentoy BTW. I guess there's some new version of OpenSSL that doesn't like the way BitlBee uses it. Even though my Debian testing system has exactly the same version but doesn't have this problem at all...

comment:2 Changed at 2008-03-19T12:37:16Z by bitlbee@…

Could reproduce here on debian etch with bitlbee 1.2. With my google talk account, no problem, but with another account (an ejabberd server, don't remember the exact version but could find out), it hangs when getting the buddy list if compiled against openssl, it's ok with gnutls. Same issue if I use SSL on dedicated port or TLS.

I have: /ctcp version says: BitlBee 1.2 Linux/i686 gnutls 1.4.4-3 openssl 0.9.8c-4etch1 cpuinfo says: model name : VIA Esther processor 2000MHz

comment:3 Changed at 2008-03-19T12:46:08Z by wilmer

Ok, interesting. Can I have an account on that server? I tried reproducing this with a account but without success. :-(

Please do note that the OpenSSL module is officially unsupported. GnuTLS is the best option.

comment:4 Changed at 2008-03-22T17:46:32Z by wilmer

Milestone: 1.2.1

comment:5 Changed at 2008-03-23T14:31:13Z by wilmer

Resolution: fixed
Status: newclosed

Yay. Turns out the size of the contact list is more important than the OpenSSL version or whatever. Problem solved in changeset:devel,359.

Modify Ticket

as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.