Ignore:
File:
1 edited

Legend:

Unmodified
Added
Removed
  • debian/rules

    r9459ca2 rf8d2cff  
    3535HAS_DH_SYSTEMD:=$(shell dpkg-query -W -f='$${Status}' dh-systemd 2>/dev/null | grep -c "ok installed")
    3636
    37 # No difference at the build stage so just call main build target.
    38 # (Well indep could be docs-only but we prebuild them plus it's really
    39 # not that much work.)
    40 build-arch build-indep: build
     37build-arch: build
    4138
    4239build: build-stamp
     
    4542
    4643        mkdir -p debian/build-native
    47         ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --systemdsystemunitdir=/lib/systemd/system $(BITLBEE_CONFIGURE_FLAGS)
     44        ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --systemdsystemunitdir=/lib/systemd/system --pcdir=/usr/lib/${DEB_HOST_MULTIARCH}/pkgconfig $(BITLBEE_CONFIGURE_FLAGS)
    4845        $(MAKE) -C debian/build-native
    4946
    5047ifeq ($(BITLBEE_LIBPURPLE),1)
    5148        mkdir -p debian/build-libpurple
    52         ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --systemdsystemunitdir=/lib/systemd/system --purple=1 $(BITLBEE_CONFIGURE_FLAGS)
     49        ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --systemdsystemunitdir=/lib/systemd/system --pcdir=/usr/lib/${DEB_HOST_MULTIARCH}/pkgconfig --purple=1 $(BITLBEE_CONFIGURE_FLAGS)
    5350        $(MAKE) -C debian/build-libpurple
    5451endif
     
    9895        dh_installchangelogs doc/CHANGES
    9996        dh_installexamples
    100         dh_installdocs #--link-doc=bitlbee-common
    101         # TODO: Restore --link-doc up here and remove the hack below once
    102         # Hardy and Lenny are deprecated.
    103         for p in bitlbee bitlbee-libpurple bitlbee-dev bitlbee-plugin-otr; do rm -r debian/$$p/usr/share/doc/$$p && ln -s bitlbee-common debian/$$p/usr/share/doc/$$p || true; done
     97        dh_installdocs --link-doc=bitlbee-common
    10498        dh_installdebconf
    10599ifeq ($(HAS_DH_SYSTEMD),1)
     
    123117        dh_builddeb
    124118
    125 binary-indep: build install
    126         DH_OPTIONS=-i $(MAKE) -f debian/rules binary-common
    127 
    128119binary-arch: build install
    129120        DH_OPTIONS=-a $(MAKE) -f debian/rules binary-common
     
    132123        DH_OPTIONS=-p$* $(MAKE) -f debian/rules binary-common
    133124
    134 binary: binary-indep binary-arch
    135 .PHONY: build clean binary-indep binary-arch binary-common binary install
     125binary: binary-arch
     126.PHONY: build clean binary-arch binary-common binary install
Note: See TracChangeset for help on using the changeset viewer.