Changes in debian/rules [9459ca2:f8d2cff]
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
debian/rules
r9459ca2 rf8d2cff 35 35 HAS_DH_SYSTEMD:=$(shell dpkg-query -W -f='$${Status}' dh-systemd 2>/dev/null | grep -c "ok installed") 36 36 37 # No difference at the build stage so just call main build target. 38 # (Well indep could be docs-only but we prebuild them plus it's really 39 # not that much work.) 40 build-arch build-indep: build 37 build-arch: build 41 38 42 39 build: build-stamp … … 45 42 46 43 mkdir -p debian/build-native 47 ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --systemdsystemunitdir=/lib/systemd/system $(BITLBEE_CONFIGURE_FLAGS)44 ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --systemdsystemunitdir=/lib/systemd/system --pcdir=/usr/lib/${DEB_HOST_MULTIARCH}/pkgconfig $(BITLBEE_CONFIGURE_FLAGS) 48 45 $(MAKE) -C debian/build-native 49 46 50 47 ifeq ($(BITLBEE_LIBPURPLE),1) 51 48 mkdir -p debian/build-libpurple 52 ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --systemdsystemunitdir=/lib/systemd/system --p urple=1 $(BITLBEE_CONFIGURE_FLAGS)49 ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --systemdsystemunitdir=/lib/systemd/system --pcdir=/usr/lib/${DEB_HOST_MULTIARCH}/pkgconfig --purple=1 $(BITLBEE_CONFIGURE_FLAGS) 53 50 $(MAKE) -C debian/build-libpurple 54 51 endif … … 98 95 dh_installchangelogs doc/CHANGES 99 96 dh_installexamples 100 dh_installdocs #--link-doc=bitlbee-common 101 # TODO: Restore --link-doc up here and remove the hack below once 102 # Hardy and Lenny are deprecated. 103 for p in bitlbee bitlbee-libpurple bitlbee-dev bitlbee-plugin-otr; do rm -r debian/$$p/usr/share/doc/$$p && ln -s bitlbee-common debian/$$p/usr/share/doc/$$p || true; done 97 dh_installdocs --link-doc=bitlbee-common 104 98 dh_installdebconf 105 99 ifeq ($(HAS_DH_SYSTEMD),1) … … 123 117 dh_builddeb 124 118 125 binary-indep: build install126 DH_OPTIONS=-i $(MAKE) -f debian/rules binary-common127 128 119 binary-arch: build install 129 120 DH_OPTIONS=-a $(MAKE) -f debian/rules binary-common … … 132 123 DH_OPTIONS=-p$* $(MAKE) -f debian/rules binary-common 133 124 134 binary: binary- indep binary-arch135 .PHONY: build clean binary- indep binary-arch binary-common binary install125 binary: binary-arch 126 .PHONY: build clean binary-arch binary-common binary install
Note: See TracChangeset
for help on using the changeset viewer.