Changeset c43f488


Ignore:
Timestamp:
2012-06-04T10:58:51Z (8 years ago)
Author:
Wilmer van der Gaast <wilmer@…>
Branches:
master
Children:
0153ba9
Parents:
7d2ce9a
Message:

Remove two hacks for some glib<2.14 versions that are no longer supported.

Files:
2 edited

Legend:

Unmodified
Added
Removed
  • protocols/twitter/twitter_lib.c

    r7d2ce9a rc43f488  
    3939#include <ctype.h>
    4040#include <errno.h>
    41 
    42 /* GLib < 2.12.0 doesn't have g_ascii_strtoll(), work around using system strtoll(). */
    43 /* GLib < 2.12.4 can be buggy: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=488013 */
    44 #if !GLIB_CHECK_VERSION(2,12,5)
    45 #include <stdlib.h>
    46 #include <limits.h>
    47 #define g_ascii_strtoll strtoll
    48 #endif
    4941
    5042#define TXL_STATUS 1
  • storage_xml.c

    r7d2ce9a rc43f488  
    3030#include "md5.h"
    3131
    32 #if GLIB_CHECK_VERSION(2,8,0)
    3332#include <glib/gstdio.h>
    34 #else
    35 /* GLib < 2.8.0 doesn't have g_access, so just use the system access(). */
    36 #include <unistd.h>
    37 #define g_access access
    38 #endif
    3933
    4034typedef enum
Note: See TracChangeset for help on using the changeset viewer.