Changeset b5fb903 for debian


Ignore:
Timestamp:
2017-01-27T00:46:49Z (2 years ago)
Author:
dequis <dx@…>
Branches:
master
Children:
eaffd0d
Parents:
b8bc398
git-author:
dequis <dx@…> (27-01-17 00:44:52)
git-committer:
dequis <dx@…> (27-01-17 00:46:49)
Message:

debian: Merge changes from 3.4.2-1.1 NMU into 3.5-1

Because apparently not having build-arch is now a build failure, even
though lintian only considered it a warning and a "recommended" target

Location:
debian
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • debian/changelog

    rb8bc398 rb5fb903  
     1bitlbee (3.5-1.1) UNRELEASED; urgency=medium
     2
     3  [ Michael Lustfield ]
     4  * Adding build-{arch,indep} targets. (Closes: #821967)
     5  * Added python to build depends.
     6
     7  [ dequis ]
     8  * Merge changes from 3.4.2-1.1 NMU into 3.5-1
     9
     10 -- dequis <dx@dxzone.com.ar>  Thu, 26 Jan 2017 21:39:24 -0300
     11
    112bitlbee (3.5-1) unstable; urgency=medium
    213
  • debian/control

    rb8bc398 rb5fb903  
    55Uploaders: Jelmer Vernooij <jelmer@debian.org>
    66Standards-Version: 3.9.8
    7 Build-Depends: libglib2.0-dev (>= 2.4), libevent-dev, libgnutls28-dev | libgnutls-dev | gnutls-dev, po-debconf, libpurple-dev, libotr5-dev, debhelper (>= 6.0.7~), dh-systemd (>= 1.5) | debhelper (<< 9.20131227)
     7Build-Depends: libglib2.0-dev (>= 2.4), libevent-dev, libgnutls28-dev | libgnutls-dev | gnutls-dev, po-debconf, libpurple-dev, libotr5-dev, debhelper (>= 6.0.7~), dh-systemd (>= 1.5) | debhelper (<< 9.20131227), python
    88Homepage: http://www.bitlbee.org/
    99Vcs-Git: https://github.com/bitlbee/bitlbee
  • debian/rules

    rb8bc398 rb5fb903  
    4141
    4242HAS_DH_SYSTEMD:=$(shell dpkg-query -W -f='$${Status}' dh-systemd 2>/dev/null | grep -c "ok installed")
     43# https://bugs.debian.org/821967
     44build-indep: binary-indep
     45build-arch: binary-arch
    4346
    4447build: build-stamp
Note: See TracChangeset for help on using the changeset viewer.