Changeset a8aa823


Ignore:
Timestamp:
2013-12-07T12:49:28Z (7 years ago)
Author:
Wilmer van der Gaast <wilmer@…>
Branches:
master
Children:
48b75f1
Parents:
434a2d0
Message:

Ugly: Bogus dependency on libotr2-dev, but adding a warning to the configure
script that this actually won't work.

This because I can't figure out how to make a source dependency conditional
on whether a certain binary packages is going to be built. It's kind of okay
since libotr2-dev is unavailable on new systems anyway.

Files:
2 edited

Legend:

Unmodified
Added
Removed
  • configure

    r434a2d0 ra8aa823  
    512512        echo 'OTR_PI=otr.so' >> Makefile.settings
    513513fi
     514if [ "$otr" != 0 ] && ! pkg-config libotr --atleast-version=4.0; then
     515        echo
     516        echo 'WARNING: Your libotr seems to be old. BitlBee now needs at least libotr 4.0.'
     517        # Not hard-failing because the code above doesn't use pkg-config, so who knows
     518        # what's true at this point...
     519fi
    514520
    515521if [ "$skype" = "1" -o "$skype" = "plugin" ]; then
  • debian/control

    r434a2d0 ra8aa823  
    55Uploaders: Jelmer Vernooij <jelmer@samba.org>
    66Standards-Version: 3.9.1
    7 Build-Depends: libglib2.0-dev (>= 2.4), libevent-dev, gnutls-dev | libgnutls-dev, po-debconf, libpurple-dev, libotr5-dev, debhelper (>= 6.0.7~), asciidoc
     7Build-Depends: libglib2.0-dev (>= 2.4), libevent-dev, gnutls-dev | libgnutls-dev, po-debconf, libpurple-dev, libotr5-dev | libotr2-dev, debhelper (>= 6.0.7~), asciidoc
    88Homepage: http://www.bitlbee.org/
    99Vcs-Bzr: http://code.bitlbee.org/bitlbee/
Note: See TracChangeset for help on using the changeset viewer.