Ignore:
File:
1 edited

Legend:

Unmodified
Added
Removed
  • debian/rules

    rf8d2cff r9459ca2  
    3535HAS_DH_SYSTEMD:=$(shell dpkg-query -W -f='$${Status}' dh-systemd 2>/dev/null | grep -c "ok installed")
    3636
    37 build-arch: build
     37# No difference at the build stage so just call main build target.
     38# (Well indep could be docs-only but we prebuild them plus it's really
     39# not that much work.)
     40build-arch build-indep: build
    3841
    3942build: build-stamp
     
    4245
    4346        mkdir -p debian/build-native
    44         ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --systemdsystemunitdir=/lib/systemd/system --pcdir=/usr/lib/${DEB_HOST_MULTIARCH}/pkgconfig $(BITLBEE_CONFIGURE_FLAGS)
     47        ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --systemdsystemunitdir=/lib/systemd/system $(BITLBEE_CONFIGURE_FLAGS)
    4548        $(MAKE) -C debian/build-native
    4649
    4750ifeq ($(BITLBEE_LIBPURPLE),1)
    4851        mkdir -p debian/build-libpurple
    49         ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --systemdsystemunitdir=/lib/systemd/system --pcdir=/usr/lib/${DEB_HOST_MULTIARCH}/pkgconfig --purple=1 $(BITLBEE_CONFIGURE_FLAGS)
     52        ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --systemdsystemunitdir=/lib/systemd/system --purple=1 $(BITLBEE_CONFIGURE_FLAGS)
    5053        $(MAKE) -C debian/build-libpurple
    5154endif
     
    9598        dh_installchangelogs doc/CHANGES
    9699        dh_installexamples
    97         dh_installdocs --link-doc=bitlbee-common
     100        dh_installdocs #--link-doc=bitlbee-common
     101        # TODO: Restore --link-doc up here and remove the hack below once
     102        # Hardy and Lenny are deprecated.
     103        for p in bitlbee bitlbee-libpurple bitlbee-dev bitlbee-plugin-otr; do rm -r debian/$$p/usr/share/doc/$$p && ln -s bitlbee-common debian/$$p/usr/share/doc/$$p || true; done
    98104        dh_installdebconf
    99105ifeq ($(HAS_DH_SYSTEMD),1)
     
    117123        dh_builddeb
    118124
     125binary-indep: build install
     126        DH_OPTIONS=-i $(MAKE) -f debian/rules binary-common
     127
    119128binary-arch: build install
    120129        DH_OPTIONS=-a $(MAKE) -f debian/rules binary-common
     
    123132        DH_OPTIONS=-p$* $(MAKE) -f debian/rules binary-common
    124133
    125 binary: binary-arch
    126 .PHONY: build clean binary-arch binary-common binary install
     134binary: binary-indep binary-arch
     135.PHONY: build clean binary-indep binary-arch binary-common binary install
Note: See TracChangeset for help on using the changeset viewer.