Changes in debian/rules [f8d2cff:9459ca2]
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
debian/rules
rf8d2cff r9459ca2 35 35 HAS_DH_SYSTEMD:=$(shell dpkg-query -W -f='$${Status}' dh-systemd 2>/dev/null | grep -c "ok installed") 36 36 37 build-arch: build 37 # No difference at the build stage so just call main build target. 38 # (Well indep could be docs-only but we prebuild them plus it's really 39 # not that much work.) 40 build-arch build-indep: build 38 41 39 42 build: build-stamp … … 42 45 43 46 mkdir -p debian/build-native 44 ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --systemdsystemunitdir=/lib/systemd/system --pcdir=/usr/lib/${DEB_HOST_MULTIARCH}/pkgconfig$(BITLBEE_CONFIGURE_FLAGS)47 ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --systemdsystemunitdir=/lib/systemd/system $(BITLBEE_CONFIGURE_FLAGS) 45 48 $(MAKE) -C debian/build-native 46 49 47 50 ifeq ($(BITLBEE_LIBPURPLE),1) 48 51 mkdir -p debian/build-libpurple 49 ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --systemdsystemunitdir=/lib/systemd/system --p cdir=/usr/lib/${DEB_HOST_MULTIARCH}/pkgconfig --purple=1 $(BITLBEE_CONFIGURE_FLAGS)52 ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --systemdsystemunitdir=/lib/systemd/system --purple=1 $(BITLBEE_CONFIGURE_FLAGS) 50 53 $(MAKE) -C debian/build-libpurple 51 54 endif … … 95 98 dh_installchangelogs doc/CHANGES 96 99 dh_installexamples 97 dh_installdocs --link-doc=bitlbee-common 100 dh_installdocs #--link-doc=bitlbee-common 101 # TODO: Restore --link-doc up here and remove the hack below once 102 # Hardy and Lenny are deprecated. 103 for p in bitlbee bitlbee-libpurple bitlbee-dev bitlbee-plugin-otr; do rm -r debian/$$p/usr/share/doc/$$p && ln -s bitlbee-common debian/$$p/usr/share/doc/$$p || true; done 98 104 dh_installdebconf 99 105 ifeq ($(HAS_DH_SYSTEMD),1) … … 117 123 dh_builddeb 118 124 125 binary-indep: build install 126 DH_OPTIONS=-i $(MAKE) -f debian/rules binary-common 127 119 128 binary-arch: build install 120 129 DH_OPTIONS=-a $(MAKE) -f debian/rules binary-common … … 123 132 DH_OPTIONS=-p$* $(MAKE) -f debian/rules binary-common 124 133 125 binary: binary- arch126 .PHONY: build clean binary- arch binary-common binary install134 binary: binary-indep binary-arch 135 .PHONY: build clean binary-indep binary-arch binary-common binary install
Note: See TracChangeset
for help on using the changeset viewer.