Changeset 235b51a for protocols


Ignore:
Timestamp:
2016-06-11T20:40:33Z (3 years ago)
Author:
dx <dx@…>
Branches:
master
Children:
135271c, 7949d5a
Parents:
e9a3e8c
git-author:
Marius Halden <marius.h@…> (11-06-16 20:40:33)
git-committer:
dx <dx@…> (11-06-16 20:40:33)
Message:

Use correct error when no schemes are supported (#78)

This will make bitlbee tell the user about the requirement for oauth
when the server actually announces support for oauth. If the server does
not announce oauth support bitlbee will tell the user it doesn't support
any of the schemes provided by the server.

These messages were reversed before.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • protocols/jabber/sasl.c

    re9a3e8c r235b51a  
    9090
    9191        if (!want_oauth && !sup_plain && !sup_digest) {
    92                 if (!sup_gtalk) {
     92                if (sup_gtalk) {
    9393                        imcb_error(ic, "This server requires OAuth "
    9494                                   "(supported schemes:%s)", mechs->str);
Note: See TracChangeset for help on using the changeset viewer.