source: debian/rules @ 763a3ab

Last change on this file since 763a3ab was 763a3ab, checked in by Wilmer van der Gaast <wilmer@…>, at 2010-08-18T10:01:10Z

Pass the -Npackage flag the right way so bitlbee-libpurple doesn't appear
in debian/files. The previous hack broke genchanges/debsign.

  • Property mode set to 100755
File size: 3.2 KB
RevLine 
[19a8088]1#!/usr/bin/make -f
[095a5f0]2#
3# Finally switching to debhelper.
4#
5# Not using debhelper was an exercise suggested to me by my AM (Gergely
6# Nagy). It was educating at the time but I finally decided that the
7# exercise is over now.
8#
[19a8088]9
[d20ea9f]10# Include the bitlbee-libpurple variant by default
11BITLBEE_LIBPURPLE ?= 1
[b5b40ff]12BITLBEE_CONFIGURE_FLAGS ?=
[19a8088]13DEBUG ?= 0
14
[4c03881]15ifndef BITLBEE_VERSION
[19a8088]16# Want to use the full package version number instead of just the release.
[095a5f0]17BITLBEE_CONFIGURE_VERSION ?= BITLBEE_VERSION=\"$(shell dpkg-parsechangelog | grep ^Version: | awk '{print $$2}')\"
[379c08a]18endif
[19a8088]19
[763a3ab]20ifneq ($(BITLBEE_LIBPURPLE),1)
21DH_OPTIONS += -Nbitlbee-libpurple
22endif
23
[095a5f0]24build: build-stamp
25build-stamp:
26        dh_testdir
[19a8088]27
[4772500]28        mkdir -p debian/build-native
[095a5f0]29        ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent $(BITLBEE_CONFIGURE_FLAGS)
30        $(MAKE) -C debian/build-native
[19a8088]31
[d20ea9f]32ifeq ($(BITLBEE_LIBPURPLE),1)
[4772500]33        mkdir -p debian/build-libpurple
[095a5f0]34        ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --purple=1 $(BITLBEE_CONFIGURE_FLAGS)
35        $(MAKE) -C debian/build-libpurple
[d20ea9f]36endif
[19a8088]37
[bc49ec2]38        $(MAKE) -C doc
39
[095a5f0]40        touch build-stamp
[46d4230]41
[095a5f0]42clean:
43        dh_testdir
44        dh_testroot
45        rm -f build-stamp
[46d4230]46
[5b94e9e]47        rm -rf build-arch-stamp debian/build-* debian/bitlbee-libpurple.prerm
[095a5f0]48        $(MAKE) distclean
[46d4230]49
[095a5f0]50        dh_clean
51
52install: build
53        dh_testdir
54        dh_testroot
[560d0a0]55        dh_clean -k
[095a5f0]56        dh_installdirs
57
[5b94e9e]58        $(MAKE) -C debian/build-native install DESTDIR=`pwd`/debian/bitlbee
59        $(MAKE) -C debian/build-native install-etc DESTDIR=`pwd`/debian/bitlbee-common
[095a5f0]60        $(MAKE) -C debian/build-native install-dev DESTDIR=`pwd`/debian/bitlbee-dev
[5b94e9e]61        patch debian/bitlbee-common/etc/bitlbee/bitlbee.conf debian/patches/bitlbee.conf.diff
[d20ea9f]62
63ifeq ($(BITLBEE_LIBPURPLE),1)
[5b94e9e]64        $(MAKE) -C debian/build-libpurple install DESTDIR=`pwd`/debian/bitlbee-libpurple
65        ln -sf debian/bitlbee.prerm debian/bitlbee-libpurple.prerm
[d20ea9f]66endif
[095a5f0]67
68        mkdir -p debian/bitlbee-common/usr
69        mv debian/bitlbee/usr/share debian/bitlbee-common/usr
70        rm -rf debian/bitlbee-libpurple/usr/share
71
72binary-common:
73        dh_testdir
74        dh_testroot
75
[4772500]76        dh_installchangelogs doc/CHANGES
[095a5f0]77        dh_installexamples
[560d0a0]78        dh_installdocs #--link-doc=bitlbee-common
79        # TODO: Restore --link-doc up here and remove the hack below once
80        # Hardy and Lenny are deprecated.
[d20ea9f]81        for p in bitlbee bitlbee-libpurple bitlbee-dev; do rm -r debian/$$p/usr/share/doc/$$p && ln -s bitlbee-common debian/$$p/usr/share/doc/$$p; done
[095a5f0]82        dh_installdebconf
[5b94e9e]83        dh_installinit --init-script=bitlbee
[095a5f0]84        dh_installman
85        dh_strip
86        dh_link
87        dh_compress
88        dh_fixperms
89        dh_installdeb
90        dh_shlibdeps
[4c03881]91ifdef BITLBEE_VERSION
[4772500]92        dh_gencontrol -- -v1:$(BITLBEE_VERSION)-0  -Vbee:Version=1:$(BITLBEE_VERSION)-0
[095a5f0]93else
[8f984a0]94        dh_gencontrol -- -Vbee:Version=$(shell dpkg-parsechangelog | grep ^Version: | awk '{print $$2}' | sed -e 's/+b[0-9]\+$$//')
[095a5f0]95endif
96        dh_md5sums
97        dh_builddeb
[46d4230]98
[095a5f0]99binary-indep: build install
[763a3ab]100        DH_OPTIONS=-i $(MAKE) -f debian/rules binary-common
[46d4230]101
[095a5f0]102binary-arch: build install
[763a3ab]103        DH_OPTIONS=-a $(MAKE) -f debian/rules binary-common
[19a8088]104
[095a5f0]105binary-%: build install
[763a3ab]106        DH_OPTIONS=-p$* $(MAKE) -f debian/rules binary-common
[19a8088]107
[095a5f0]108binary: binary-indep binary-arch
109.PHONY: build clean binary-indep binary-arch binary-common binary install
Note: See TracBrowser for help on using the repository browser.