source: debian/rules @ 135271c

Last change on this file since 135271c was 135271c, checked in by dequis <dx@…>, at 2016-06-12T08:34:56Z

debian: install systemd units and use dh_systemd

I'm using the debhelper version (9.20131227) to avoid depending on
dh_systemd for debian wheezy and ubuntu precise. If it's older than
that, it's probably a distro without dh_systemd.

  • Property mode set to 100755
File size: 4.3 KB
RevLine 
[19a8088]1#!/usr/bin/make -f
[095a5f0]2#
3# Finally switching to debhelper.
4#
5# Not using debhelper was an exercise suggested to me by my AM (Gergely
6# Nagy). It was educating at the time but I finally decided that the
7# exercise is over now.
8#
[19a8088]9
[6c0fe9b]10# Include the bitlbee-libpurple variant and OTR plugin by default.
11# Don't build skype by default since it depends on deleted/non-free
12# packages. Need to at least get python-skype back into Debian.
[d20ea9f]13BITLBEE_LIBPURPLE ?= 1
[27b407f]14BITLBEE_OTR ?= plugin
[6c0fe9b]15BITLBEE_SKYPE ?= 0
[b5b40ff]16BITLBEE_CONFIGURE_FLAGS ?=
[19a8088]17DEBUG ?= 0
18
[4c03881]19ifndef BITLBEE_VERSION
[19a8088]20# Want to use the full package version number instead of just the release.
[0edb57f]21BITLBEE_CONFIGURE_VERSION ?= BITLBEE_VERSION="$(shell dpkg-parsechangelog | awk '/^Version:/ {print $$2}')"
[379c08a]22endif
[19a8088]23
[763a3ab]24ifneq ($(BITLBEE_LIBPURPLE),1)
25DH_OPTIONS += -Nbitlbee-libpurple
26endif
27
[27b407f]28ifneq ($(BITLBEE_OTR),plugin)
29DH_OPTIONS += -Nbitlbee-plugin-otr
30endif
31
[57da960]32ifneq ($(BITLBEE_SKYPE),plugin)
33DH_OPTIONS += -Nbitlbee-plugin-skype -Nskyped
34endif
35
[e01ff50]36CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
37CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
38LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
39
40CONFIGURE_OVERRIDES:=CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
41
[135271c]42HAS_DH_SYSTEMD:=$(shell dpkg-query -W -f='$${Status}' dh-systemd 2>/dev/null | grep -c "ok installed")
43
[095a5f0]44build: build-stamp
45build-stamp:
46        dh_testdir
[19a8088]47
[4772500]48        mkdir -p debian/build-native
[e01ff50]49        ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --skype=$(BITLBEE_SKYPE) $(BITLBEE_CONFIGURE_FLAGS)
[095a5f0]50        $(MAKE) -C debian/build-native
[19a8088]51
[d20ea9f]52ifeq ($(BITLBEE_LIBPURPLE),1)
[4772500]53        mkdir -p debian/build-libpurple
[e01ff50]54        ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --purple=1 $(BITLBEE_CONFIGURE_FLAGS)
[095a5f0]55        $(MAKE) -C debian/build-libpurple
[d20ea9f]56endif
[19a8088]57
[bc49ec2]58        $(MAKE) -C doc
[0d8add8a]59        $(MAKE) -C doc/user-guide
[bc49ec2]60
[095a5f0]61        touch build-stamp
[46d4230]62
[095a5f0]63clean:
64        dh_testdir
65        dh_testroot
66        rm -f build-stamp
[46d4230]67
[5b94e9e]68        rm -rf build-arch-stamp debian/build-* debian/bitlbee-libpurple.prerm
[095a5f0]69        $(MAKE) distclean
[46d4230]70
[095a5f0]71        dh_clean
72
73install: build
74        dh_testdir
75        dh_testroot
[e9a3e8c]76        dh_prep
[095a5f0]77        dh_installdirs
78
[27b407f]79        $(MAKE) -C debian/build-native install-bin DESTDIR=`pwd`/debian/bitlbee
80        $(MAKE) -C debian/build-native install-etc install-doc DESTDIR=`pwd`/debian/bitlbee-common
[095a5f0]81        $(MAKE) -C debian/build-native install-dev DESTDIR=`pwd`/debian/bitlbee-dev
[57da960]82        $(MAKE) -C debian/build-native install-plugin-otr DESTDIR=`pwd`/debian/bitlbee-plugin-otr
83        $(MAKE) -C debian/build-native install-plugin-skype DESTDIR=`pwd`/debian/skyped
84
[135271c]85ifeq ($(HAS_DH_SYSTEMD),1)
86        $(MAKE) -C debian/build-native install-systemd DESTDIR=`pwd`/debian/bitlbee-common
87endif
88
[6c0fe9b]89ifneq ($(BITLBEE_SKYPE),0)
[57da960]90        mkdir -p debian/bitlbee-plugin-skype/usr
91        mv debian/skyped/usr/lib debian/bitlbee-plugin-skype/usr
[d20ea9f]92
[e46db53]93        mkdir -p debian/skyped/usr/share/man/man1
94        mv debian/bitlbee-common/usr/share/man/man1/skyped* debian/skyped/usr/share/man/man1
[6c0fe9b]95endif
[e46db53]96
[d20ea9f]97ifeq ($(BITLBEE_LIBPURPLE),1)
[27b407f]98        $(MAKE) -C debian/build-libpurple install-bin DESTDIR=`pwd`/debian/bitlbee-libpurple
[5b94e9e]99        ln -sf debian/bitlbee.prerm debian/bitlbee-libpurple.prerm
[d20ea9f]100endif
[095a5f0]101
[27b407f]102        patch debian/bitlbee-common/etc/bitlbee/bitlbee.conf debian/patches/bitlbee.conf.diff
103        chmod 640 debian/bitlbee-common/etc/bitlbee/bitlbee.conf
[095a5f0]104
105binary-common:
106        dh_testdir
107        dh_testroot
108
[4772500]109        dh_installchangelogs doc/CHANGES
[095a5f0]110        dh_installexamples
[560d0a0]111        dh_installdocs #--link-doc=bitlbee-common
112        # TODO: Restore --link-doc up here and remove the hack below once
113        # Hardy and Lenny are deprecated.
[27b407f]114        for p in bitlbee bitlbee-libpurple bitlbee-dev bitlbee-plugin-otr; do rm -r debian/$$p/usr/share/doc/$$p && ln -s bitlbee-common debian/$$p/usr/share/doc/$$p || true; done
[095a5f0]115        dh_installdebconf
[135271c]116ifeq ($(HAS_DH_SYSTEMD),1)
117        dh_systemd_enable
[5b94e9e]118        dh_installinit --init-script=bitlbee
[135271c]119        dh_systemd_start
120else
121        dh_installinit --init-script=bitlbee
122endif
[095a5f0]123        dh_installman
[6c2b430]124        dh_lintian
[095a5f0]125        dh_strip
126        dh_link
127        dh_compress
128        dh_fixperms
129        dh_installdeb
130        dh_shlibdeps
[256164c]131        dh_gencontrol
[095a5f0]132        dh_md5sums
133        dh_builddeb
[46d4230]134
[095a5f0]135binary-indep: build install
[763a3ab]136        DH_OPTIONS=-i $(MAKE) -f debian/rules binary-common
[46d4230]137
[095a5f0]138binary-arch: build install
[763a3ab]139        DH_OPTIONS=-a $(MAKE) -f debian/rules binary-common
[19a8088]140
[095a5f0]141binary-%: build install
[763a3ab]142        DH_OPTIONS=-p$* $(MAKE) -f debian/rules binary-common
[19a8088]143
[095a5f0]144binary: binary-indep binary-arch
145.PHONY: build clean binary-indep binary-arch binary-common binary install
Note: See TracBrowser for help on using the repository browser.