Modify

Opened 5 years ago

Closed 5 years ago

#650 closed defect (fixed)

Bitlbee segfaults due to twitter protocol

Reported by: wahjava@… Owned by:
Priority: normal Milestone:
Component: BitlBee Version: 1.2.7
Keywords: Cc:
IRC client+version: Client-independent Operating System: FreeBSD
OS version/distro: 8.0-RELEASE-p3

Description

When the <status> tag in the timelines doesn't have an associated <user> tag (which happens due to a bug in StatusNet where user profile is deleted without deleting the notice), Bitlbee segfaults. The attached diff fixes this issue for me.

Thanks Ashish SHUKLA -- P.S. The issue isn't OS specific.

Attachments (1)

patch-protocols_twitter_twitter__lib.c (1.8 KB) - added by wahjava@… 5 years ago.
diff for protocols/twitter/twitter_lib.c

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by wahjava@…

diff for protocols/twitter/twitter_lib.c

comment:1 Changed 5 years ago by wilmer

  • Resolution set to fixed
  • Status changed from new to closed

Whoops. Thanks for fixing that. Submitted in changeset:devel,607. I went for a slightly different approach, checking for NULL pointers inside the _free functions.

There may very well be more bugs like that there. :-/

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.